summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-31 10:12:32 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-31 12:14:35 +0200
commit1a0a5da2814e634293cf0fcb681ee9f1eb24882e (patch)
tree708132e1b17d6d554fab56b59cabcefc88597f35 /dev-python/pylint
parentdev-python/wurlitzer: Bump to 2.1.0 (diff)
downloadgentoo-1a0a5da2814e634293cf0fcb681ee9f1eb24882e.tar.gz
gentoo-1a0a5da2814e634293cf0fcb681ee9f1eb24882e.tar.bz2
gentoo-1a0a5da2814e634293cf0fcb681ee9f1eb24882e.zip
dev-python/pylint: Bump to 2.7.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.7.4.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index bfbf0cdc5707..b469f093ae40 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,2 +1,3 @@
DIST pylint-2.7.1.tar.gz 708916 BLAKE2B 606637ff25daccba741ae5bcdecb6a2be50bc17393009193a29312b4a218622d23287a0f0c5a81e79e77cc54dfe529483ad01fa39445103f240addaa3ad58bf7 SHA512 eebf1d3da5ca072cb912ecffebf183c79f2f8b2c2b14044751aad202d75d06d1c06abb561d4581990b92fe54c06b570a1de39b792b0d729cf300c01c82c4e3c0
DIST pylint-2.7.2.tar.gz 709177 BLAKE2B 5e4daeb19b6b18d570f4d78b01cc5023d5d245840160fdbddb194ab7036118742ffe3075ee27c37bd7a700d11d9006dc9abaaba9cf9596ae1b63941f139da7ac SHA512 800b210fbe5665db390d5c885d103856dc474b4e43d2f752bdcfcea36121132c26eecdcb67620c4a90456823f11a33568de4d37d59eea692dcd1751d931420f7
+DIST pylint-2.7.4.tar.gz 715507 BLAKE2B 141506c067195422d0b052924baf87c363c89e28b3279f5173d989ac9247163184840251bd05dfb7dbb765f7b2e921a851fde0323b6c4cc231bc58911c77f692 SHA512 2b7ec9ab3325209021cb0282a6dacabf7ddd1f5e4049157610015ac8c11413471defc9e0528f81e1a60c2b259260f1bde1d04286776b3f32f771968b9866d734
diff --git a/dev-python/pylint/pylint-2.7.4.ebuild b/dev-python/pylint/pylint-2.7.4.ebuild
new file mode 100644
index 000000000000..def4ed8778bd
--- /dev/null
+++ b/dev-python/pylint/pylint-2.7.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="https://www.logilab.org/project/pylint
+ https://pypi.org/project/pylint/
+ https://github.com/pycqa/pylint"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+# Mirror requirements from pylint/__pkginfo__.py
+RDEPEND="
+ <dev-python/astroid-2.6[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.5.2[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
+)
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local skipped_tests=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ # Fails when graphviz is installed (?!)
+ tests/test_import_graph.py::test_missing_graphviz
+ )
+ # Specify the test directory explicitly to avoid import file mismatches
+ epytest tests ${skipped_tests[@]/#/--deselect }
+}
+
+python_install_all() {
+ doman man/{pylint,pyreverse}.1
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}