summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-08 05:54:26 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-08 06:00:28 +0100
commit44fadaedfd7d08d3aebf4bb56c9ce776356ae7d6 (patch)
treebafbfe6a42af0b81ec6d6805b088015359cc80c8 /dev-python/pylint
parentdev-python/nbclient: Remove old (diff)
downloadgentoo-44fadaedfd7d08d3aebf4bb56c9ce776356ae7d6.tar.gz
gentoo-44fadaedfd7d08d3aebf4bb56c9ce776356ae7d6.tar.bz2
gentoo-44fadaedfd7d08d3aebf4bb56c9ce776356ae7d6.zip
dev-python/pylint: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.15.4.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 84a049a82651..b6184c8a25a0 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,2 +1 @@
-DIST pylint-2.15.4.gh.tar.gz 1312017 BLAKE2B 49be7a9288fc4186679946769fd9e88c6df504c1683ba0c070721c9223c4169c65bd0cf6344d755f30c440e5c7af98008457a8d7e6cd3d33952f083acb3f0641 SHA512 63cd8abb176092a2d43f38b6cdae5f8ec73a69e7267b6b1deb17150818d19f95be7ca07d5d75f02a9e238c60b153de5cc9294e5f93b8a5351ce0c99e9cf48216
DIST pylint-2.15.5.gh.tar.gz 1312932 BLAKE2B b8de4e16122ba0bea4cfd9ce3ec4a12abf5e408d7f9d60875eaac781a962c0d01af7691b3c110f2b895bcb7c2d47e0f868d5d52171594aaaecb53ea045a179b9 SHA512 a6e123ab516ef12be0651dbe144814d9f3f9263d61c259d79e9505ee3b4011b33e302281067aa5bacd504fa079f3a7aaceee4d1f9aad127bec8ebeddfeb2afbe
diff --git a/dev-python/pylint/pylint-2.15.4.ebuild b/dev-python/pylint/pylint-2.15.4.ebuild
deleted file mode 100644
index 6ec928376952..000000000000
--- a/dev-python/pylint/pylint-2.15.4.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="
- https://pypi.org/project/pylint/
- https://github.com/PyCQA/pylint/
-"
-SRC_URI="
- https://github.com/pycqa/pylint/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="examples"
-
-# Make sure to check https://github.com/PyCQA/pylint/blob/main/pyproject.toml#L34 on bumps
-# Adjust dep bounds!
-RDEPEND="
- <dev-python/astroid-2.14[${PYTHON_USEDEP}]
- >=dev-python/astroid-2.12.11[${PYTHON_USEDEP}]
- >=dev-python/dill-0.2[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- ' 3.8 3.9)
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
-"
-BDEPEND="
- test? (
- >=dev-python/GitPython-3[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- rm -rf pylint || die
-
- local EPYTEST_DESELECT=(
- # No need to run the benchmarks
- tests/benchmark/test_baseline_benchmarks.py
-
- # TODO
- 'tests/test_functional.py::test_functional[forgotten_debug_statement_py37]'
- 'tests/test_functional.py::test_functional[dataclass_with_field]'
- 'tests/test_functional.py::test_functional[no_name_in_module]'
- tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_error_msg
- tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_info_msg
- tests/config/pylint_config/test_run_pylint_config.py::test_invocation_of_pylint_config
- )
- epytest
-}
-
-python_install_all() {
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}