summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-15 08:43:02 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-15 08:43:02 +0100
commit5ce11ad1339c8d11c0e439b175eb7bb97c8e982b (patch)
tree1649cab46fb9e0fb595398af667ce6d3203d19a6 /dev-python/pylint
parentdev-python/vcrpy: Remove old (diff)
downloadgentoo-5ce11ad1339c8d11c0e439b175eb7bb97c8e982b.tar.gz
gentoo-5ce11ad1339c8d11c0e439b175eb7bb97c8e982b.tar.bz2
gentoo-5ce11ad1339c8d11c0e439b175eb7bb97c8e982b.zip
dev-python/pylint: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/files/pylint-2.5.3-no-pytest-runner.patch20
-rw-r--r--dev-python/pylint/pylint-2.5.3.ebuild65
3 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 099f297e9dee..a3ca45b1d138 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,2 +1 @@
-DIST pylint-2.5.3.tar.gz 684449 BLAKE2B 7b494f5334376ff571fd8971851198d037e87c5be83d0123fcb108701489769785164bb077eb10b4851c89b82dadc40c510186eaf03be1621c4d78c79dffbceb SHA512 03fcd893d361b66794f17433e90df108099fee2eccb35507c7f61befb8db846f0242e5ce2b4ee63727c9cc780a376c3b93d5af3186f884a4fdaad68b224ed7d2
DIST pylint-2.6.0.tar.gz 680289 BLAKE2B f7d4159478f667a3234beefd148857f26c8f7ea3aae3bfa70fa06fe2a8d86fcf22a0727a9fa5d8fc3de4aa0bb7a4d6e13bf68029f359122762d1e0d24a0b715b SHA512 02881fe14401bbe946618ef947c8db320a6c8dd93626402260d60468538ce67b61d1e8b921bfb1a6020514dd392e9b0021c97ddb60b45866c2d2241224f93f08
diff --git a/dev-python/pylint/files/pylint-2.5.3-no-pytest-runner.patch b/dev-python/pylint/files/pylint-2.5.3-no-pytest-runner.patch
deleted file mode 100644
index f4cc6be360de..000000000000
--- a/dev-python/pylint/files/pylint-2.5.3-no-pytest-runner.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 92d059ff..cbc5b881 100644
---- a/setup.py
-+++ b/setup.py
-@@ -67,7 +67,6 @@ else:
-
-
- needs_pytest = {"pytest", "test", "ptr"}.intersection(sys.argv)
--pytest_runner = ["pytest-runner"] if needs_pytest else []
-
-
- def ensure_scripts(linux_scripts):
-@@ -151,7 +150,6 @@ def install(**kwargs):
- extras_require=extras_require,
- test_suite="test",
- python_requires=">=3.5.*",
-- setup_requires=pytest_runner,
- tests_require=["pytest"],
- **kwargs
- )
diff --git a/dev-python/pylint/pylint-2.5.3.ebuild b/dev-python/pylint/pylint-2.5.3.ebuild
deleted file mode 100644
index 8cae6d66c8b7..000000000000
--- a/dev-python/pylint/pylint-2.5.3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-# entry_points is added via **kwargs in a dict
-_DISTUTILS_SETUPTOOLS_WARNED=1
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="https://www.logilab.org/project/pylint
- https://pypi.org/project/pylint/
- https://github.com/pycqa/pylint"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 sparc x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/astroid-2.3.3[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- dev-python/mccabe[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/six[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
- "${FILESDIR}/${PN}-2.5.3-no-pytest-runner.patch"
- "${FILESDIR}/${PN}-2.5.3-tests.patch"
-)
-
-distutils_enable_sphinx doc
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # we don't want to run the benchmarking tests
- rm -f tests/benchmark/test_baseline_benchmarks.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- doman man/{pylint,pyreverse}.1
- if use examples ; then
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- # Optional dependency on "tk" USE flag would break support for Jython.
- optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." 'dev-lang/python[tk]'
-}