summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-16 09:15:08 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-16 09:30:08 +0100
commit715d3ea217f9b142516e8a157999057d1e4b8c8e (patch)
treeac22ebbec12418a45e7e38b8de68b1bbb26ec7fe /dev-python/pylint
parentapp-emulation/lxd: don't shutdown all cluster instances with service (diff)
downloadgentoo-715d3ea217f9b142516e8a157999057d1e4b8c8e.tar.gz
gentoo-715d3ea217f9b142516e8a157999057d1e4b8c8e.tar.bz2
gentoo-715d3ea217f9b142516e8a157999057d1e4b8c8e.zip
dev-python/pylint: Bump to 2.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.6.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index a3ca45b1d138..394414d0fd8c 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1 +1,2 @@
DIST pylint-2.6.0.tar.gz 680289 BLAKE2B f7d4159478f667a3234beefd148857f26c8f7ea3aae3bfa70fa06fe2a8d86fcf22a0727a9fa5d8fc3de4aa0bb7a4d6e13bf68029f359122762d1e0d24a0b715b SHA512 02881fe14401bbe946618ef947c8db320a6c8dd93626402260d60468538ce67b61d1e8b921bfb1a6020514dd392e9b0021c97ddb60b45866c2d2241224f93f08
+DIST pylint-2.6.1.tar.gz 694232 BLAKE2B c169939a49a9a8f3225e120cf56df12fabd8d1940504231d0e1c3783dd8b87beb24e7095e15b332189043d5790b69bd2a41b0baf56cffccb4ef5d7cfe2be9cf8 SHA512 6a6bda57ed22df8378aea3de3fe3b97deb7c0742abeb08463d3d2e0f0cbf6bd2166861456b3fa7cd2d7cf148b052fc4913479c3f632b8e92ebf8d26189a122b1
diff --git a/dev-python/pylint/pylint-2.6.1.ebuild b/dev-python/pylint/pylint-2.6.1.ebuild
new file mode 100644
index 000000000000..7135b98dde48
--- /dev/null
+++ b/dev-python/pylint/pylint-2.6.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Not ready for Python 3.9 yet: https://github.com/PyCQA/pylint/issues/3895
+PYTHON_COMPAT=( python3_{7..8} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="https://www.logilab.org/project/pylint
+ https://pypi.org/project/pylint/
+ https://github.com/pycqa/pylint"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+# Mirror requirements from pylint/__pkginfo__.py
+RDEPEND="
+ >=dev-python/astroid-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/astroid-2.5[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
+ "${FILESDIR}/${PN}-2.5.3-tests.patch"
+)
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # we don't want to run the benchmarking tests
+ rm -f tests/benchmark/test_baseline_benchmarks.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ doman man/{pylint,pyreverse}.1
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}