summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-06-06 23:17:06 -0700
committerZac Medico <zmedico@gentoo.org>2018-06-06 23:28:55 -0700
commit9ed0681b6a53af77c6eca53c7fe6778c973c8fe5 (patch)
treeafbbd73fc328b9d3b48604de8ab95e1ecc6b971a /dev-python/pylint
parentdev-python/astroid: version bump to 1.6.5 (diff)
downloadgentoo-9ed0681b6a53af77c6eca53c7fe6778c973c8fe5.tar.gz
gentoo-9ed0681b6a53af77c6eca53c7fe6778c973c8fe5.tar.bz2
gentoo-9ed0681b6a53af77c6eca53c7fe6778c973c8fe5.zip
dev-python/pylint: version bump to 1.8.4
Closes: https://bugs.gentoo.org/655754 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-1.8.4.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 4beb4310b41c..349ec023c978 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -2,3 +2,4 @@ DIST pylint-1.6.5.tar.gz 465578 BLAKE2B 05412a528878633ef7529dd2f2d2d1989bc94066
DIST pylint-1.7.2.tar.gz 488628 BLAKE2B 6f2902bdd18939f251515d652d2e9df43162c1b0c27c2e2ed7392ee77be9e7f81bbd62cede4f2eb1e7aa646bf47c48b01436e04cbf46a20458a1c89eff752d9d SHA512 268f141f017fa4df6024596bcf1dfb32a578e9459864e2ace8c2725c8f5e117e0b01d9d745f1632bb43102a01f7075dc3fb69b839b79371f7df47740a56fc1cb
DIST pylint-1.7.5.tar.gz 486892 BLAKE2B 0a415045e16aeb6e8543af003cff3061756b01bcbeb9f62de7cf1a63356ff01c3a2fd079e51ee0f8b1b797dd3de29c14d9928c0b4d0214fda82fbc2dc12010c6 SHA512 9f28cc4f88b26d2299ab3ea015935fba8c96f700c7898ad8fbdecfa0902f10a4ca54ad346b18452f8a589f8b63494bc12487dab36d168f336012b259bfa6f3f8
DIST pylint-1.8.2.tar.gz 510319 BLAKE2B fd2d28d48cc5b7690428baf3e4a4ba56a6c59dd3bae6fac12046f2c087f1f6d033f4c318f2977d3ee3cc6a463a089a02364f0e38859c2eba5a39dbe6350e19ec SHA512 3cec971314bcc9ad7aa32d6641797adb0adc440414cfe982a10777ffeecfc64588f9c1d8c6d8074131b1389fe5ecb2e6aea5c24ba3047f917a60d12808b52d8c
+DIST pylint-1.8.4.tar.gz 512582 BLAKE2B 623e224ec71756cc2528346ac62b8e58ac4d5ef55d9e31e667d5389aa5b2dad712f60c7e90df5c831f57bf28e0ccbd00ddece4ade46410c28b67adb1a041a85f SHA512 07e55ed3f09326e1973215046e3b172f6065a7ed0ae657cba7a6825a26bb103bdbf8b83126bafd99f332fe0eec3547bcd6e618d6e9f612ddcf9c504bb850dcd9
diff --git a/dev-python/pylint/pylint-1.8.4.ebuild b/dev-python/pylint/pylint-1.8.4.ebuild
new file mode 100644
index 000000000000..b7148eae0d7e
--- /dev/null
+++ b/dev-python/pylint/pylint-1.8.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="https://www.logilab.org/project/pylint
+ https://pypi.org/project/pylint/
+ https://github.com/pycqa/pylint"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/astroid-1.6.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ dev-python/mccabe[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]
+ dev-python/configparser[${PYTHON_USEDEP}]' -2)"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ <dev-python/pytest-3.3[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # remove unused dep
+ sed -i -e '/pytest-runner/d' setup.py || die
+
+ # Disable failing tests
+ # TODO: investigate if it's our fault and how can we fix it
+ sed -i -e 's/io.StringIO()/\0 if sys.version_info.major > 2 else open(os.devnull, "w")/' \
+ -e 's/test_libmodule/_&/' \
+ pylint/test/acceptance/test_stdlib.py || die
+ sed -i -e 's/^# pylint:.*/\0, import-error/' \
+ pylint/test/functional/deprecated_module_py36.py || die
+ sed -i -e 's/^# pylint:.*/\0, wrong-import-order/' \
+ pylint/test/functional/generated_members.py || die
+ sed -i -e 's/test_good_comprehension_checks/_&/' \
+ pylint/test/functional/using_constant_test.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # selection of straight html triggers a trivial annoying bug, we skirt it
+ use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml
+}
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ doman man/{pylint,pyreverse}.1
+ if use examples ; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+ use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ # Optional dependency on "tk" USE flag would break support for Jython.
+ optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." 'dev-lang/python[tk]'
+}