summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-08 17:36:28 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-08 18:02:35 +0100
commitbab290c19adc12234ce062babb5d3fbcdabdc3e2 (patch)
tree39e76c183159c4e41ec62c41d3478d36b1ead26d /dev-python/pylint
parentdev-python/reno: Bump to 4.0.0 (diff)
downloadgentoo-bab290c19adc12234ce062babb5d3fbcdabdc3e2.tar.gz
gentoo-bab290c19adc12234ce062babb5d3fbcdabdc3e2.tar.bz2
gentoo-bab290c19adc12234ce062babb5d3fbcdabdc3e2.zip
dev-python/pylint: Bump to 2.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.17.0.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 1d342815da61..af6d778ca5a8 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,3 +1,4 @@
DIST pylint-2.16.2.gh.tar.gz 1382056 BLAKE2B 35c4c07fb750c884d62c9ec563e5133654b9ecef41d320976214a1cae25cd28f1681dcc3053cc358276cfc3cc76df770fbb2f7691e387bb07b6ff803f4a21d0b SHA512 36a76fa7a5ae9c4fead66a0964dd40963c51db8225ec112b0557d04ddf2f89ea9649e390c005ccc35341b2ac5f69f6ccf17652d08cba223fdcd36ccf433659bb
DIST pylint-2.16.3.gh.tar.gz 1382318 BLAKE2B 67e2e7b6facde79268267e44081e1b71e391654b959e39c0d3893e1d6ffd0a79423d3c9663e0aeaadd4321669e17799af4351bcbd2cbd51518ec5f1b4db940ab SHA512 3918c15bbf94de7a4150652dc1fc8cc2929255470198d52bcbfe1205017192e748a852aa0174bf864165ce5e9eac70e4f1a23ca3275fea3f584216c32b224b61
DIST pylint-2.16.4.gh.tar.gz 1382902 BLAKE2B 515078d2677e4374041de563ec2a98cf877848a0f1042c26f331a21335e030e15a3d6ba4eb539c18cc3835fc9505270c540b9c64f61c037759171deec41f5f10 SHA512 144a7b048340c65082f02f34d511e0066019ac08d28eb5f8c114086b66a471355631355b24f291916fa2e6b9db8e0e69a4649ad9ce036bbf2418fd6a73089fc5
+DIST pylint-2.17.0.gh.tar.gz 1406740 BLAKE2B 55176ca794f182886c93eb1461599792df90f948c09a8c4084138a7319f8127d9037d9b4535be90d5ad19227b1ce36ae07f5aaf532298aa92be97832baaba64e SHA512 2796cf670b2aa6cc448e5e26b4899804ebfdea6df3730cab06f2c72fdf57ee07b08e63f0748bce991175c67c22d040ededa19c967a2f74e14d44e54323aff945
diff --git a/dev-python/pylint/pylint-2.17.0.ebuild b/dev-python/pylint/pylint-2.17.0.ebuild
new file mode 100644
index 000000000000..94f5f61301c8
--- /dev/null
+++ b/dev-python/pylint/pylint-2.17.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/PyCQA/pylint/
+"
+SRC_URI="
+ https://github.com/pycqa/pylint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/PyCQA/pylint/blob/main/pyproject.toml#L34 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-2.17[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf pylint || die
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ 'tests/test_functional.py::test_functional[forgotten_debug_statement_py37]'
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ 'tests/test_functional.py::test_functional[shadowed_import]'
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_error_msg
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_info_msg
+ tests/config/pylint_config/test_run_pylint_config.py::test_invocation_of_pylint_config
+
+ # apparently fragile, needs unpickleable plugin
+ tests/test_check_parallel.py::TestCheckParallelFramework::test_linter_with_unpickleable_plugins_is_pickleable
+ )
+ local EPYTEST_IGNORE=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+ epytest
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}