summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-30 08:09:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-30 08:09:12 +0200
commitc41db097fde08c2fa451495d4d6c43f88ba00b97 (patch)
treed7753ada0a77a5970b2d0bcb5567676aece7fe1b /dev-python/pylint
parentdev-python/qrcode: Bump to 7.0 (diff)
downloadgentoo-c41db097fde08c2fa451495d4d6c43f88ba00b97.tar.gz
gentoo-c41db097fde08c2fa451495d4d6c43f88ba00b97.tar.bz2
gentoo-c41db097fde08c2fa451495d4d6c43f88ba00b97.zip
dev-python/pylint: Bump to 2.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.9.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 95131704246a..54ff4f787a30 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1 +1,2 @@
DIST pylint-2.8.2.gh.tar.gz 734667 BLAKE2B 1525273298f39163de4db7946a749768cb9bcf7e11f89791944ccb5fb8d0918eedfc80d5e559d33934d468dd5781d4cb4921b9407daf2842613a8e3ba7d134e0 SHA512 7023603668f540ecc0b35f3289377855c4c0df01e04a9af255f5c8031f568f6b76508bb3a7f0aba8e76a86b63eae423908c30f47258d6dee46bb23320c952701
+DIST pylint-2.9.0.gh.tar.gz 768301 BLAKE2B a86ccb83d3155acee0165dc7b0095f5b7741c62e7b1f127349eef643cd1d0513ed2f5aaa89d78728806f03b08645ed1579aafb073d649e928d4c415e50dc8a49 SHA512 b524a3d3241702c1fc34ca9ee38815d02e7f4572d8ff3c132141ac7d9c7ff59f88995b92ccfcf18fd57e04be8f24571ef0ab99e6b4ce615f0f6957022d1d1467
diff --git a/dev-python/pylint/pylint-2.9.0.ebuild b/dev-python/pylint/pylint-2.9.0.ebuild
new file mode 100644
index 000000000000..b874f1067834
--- /dev/null
+++ b/dev-python/pylint/pylint-2.9.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="https://www.logilab.org/project/pylint
+ https://pypi.org/project/pylint/
+ https://github.com/pycqa/pylint/"
+SRC_URI="
+ https://github.com/pycqa/pylint/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND="
+ <dev-python/astroid-2.7[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.6.1[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
+)
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local skipped_tests=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ # Fails when graphviz is installed (?!)
+# tests/test_import_graph.py::test_missing_graphviz
+ # TODO
+# 'tests/lint/unittest_expand_modules.py::test_expand_modules[files_or_modules1-expected1]'
+ )
+ # Specify the test directory explicitly to avoid import file mismatches
+ epytest tests ${skipped_tests[@]/#/--deselect }
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}