summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-22 17:27:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-22 21:22:17 +0100
commitcf2ece451a0e68a2174604ee44f553ff2a117b1e (patch)
tree5a626fea741e6f53c5f0f4e50e6242a8f8b720e7 /dev-python/pylint
parentdev-python/astroid: Drop 1.6.5 (diff)
downloadgentoo-cf2ece451a0e68a2174604ee44f553ff2a117b1e.tar.gz
gentoo-cf2ece451a0e68a2174604ee44f553ff2a117b1e.tar.bz2
gentoo-cf2ece451a0e68a2174604ee44f553ff2a117b1e.zip
dev-python/pylint: Drop 1.8.4
Blocks dev-python/pytest-3.10.1 cleanup. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-1.8.4.ebuild78
2 files changed, 0 insertions, 79 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 0ce1aa3a79bd..04d74c4469b7 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,4 +1,3 @@
DIST pylint-1.6.5.tar.gz 465578 BLAKE2B 05412a528878633ef7529dd2f2d2d1989bc9406666626d62764f476bbc024e34fea06883fae829fe6617ebfffde54dfa5600c140b9a25e6c9633f48d76f5c331 SHA512 2fac352dc752b37f1ce4f7fefe5afbbc880d7e6c38f164d1c50734716af1dd6fe31f7d41e145a8256837d5a63b1989efec40c169fc14840cf8eb4e18d9bb2410
-DIST pylint-1.8.4.tar.gz 512582 BLAKE2B 623e224ec71756cc2528346ac62b8e58ac4d5ef55d9e31e667d5389aa5b2dad712f60c7e90df5c831f57bf28e0ccbd00ddece4ade46410c28b67adb1a041a85f SHA512 07e55ed3f09326e1973215046e3b172f6065a7ed0ae657cba7a6825a26bb103bdbf8b83126bafd99f332fe0eec3547bcd6e618d6e9f612ddcf9c504bb850dcd9
DIST pylint-2.3.1.tar.gz 577767 BLAKE2B 2af206a9d9be04f369c2bbc39c5ddb80c29a5a39c20d75bfec84498882eab628a7cf5abcc5786933304ed99bd00ffa142b9a58abab348c947799f962b877bb30 SHA512 924d8adc95f04ba750b3b44fe79ac569151ea7c8f693cc9867bcda3878209ebc2202931702b98f80709d161d3781b6e181aea0ded35a3323c023497e2a749ea9
DIST pylint-2.4.4.tar.gz 646113 BLAKE2B d62b66b056e01cc13e90f45ff4a11f94983e0b9b42b9a05e5c7b7385280000d15ead9a282e7eea31a8ee6a24ffe539576a6e9bd40dc4d89093263da99029123b SHA512 835e0687ebc76c530e0042c5a5188b8aedab446531f621627e990cbeb37ab6ecc8de0f8c6ab171abaa63488e049e8d7782958461421f9a4127435f56b6d2ed0b
diff --git a/dev-python/pylint/pylint-1.8.4.ebuild b/dev-python/pylint/pylint-1.8.4.ebuild
deleted file mode 100644
index 1283cbb5b941..000000000000
--- a/dev-python/pylint/pylint-1.8.4.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="https://www.logilab.org/project/pylint
- https://pypi.org/project/pylint/
- https://github.com/pycqa/pylint"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/astroid-1.6.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- dev-python/mccabe[${PYTHON_USEDEP}]
- virtual/python-singledispatch[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]
- dev-python/configparser[${PYTHON_USEDEP}]' -2)"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND}
- <dev-python/pytest-4[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # remove unused dep
- sed -i -e '/pytest-runner/d' setup.py || die
-
- # Disable failing tests
- # TODO: investigate if it's our fault and how can we fix it
- sed -i -e 's/io.StringIO()/\0 if sys.version_info.major > 2 else open(os.devnull, "w")/' \
- -e 's/test_libmodule/_&/' \
- pylint/test/acceptance/test_stdlib.py || die
- sed -i -e 's/^# pylint:.*/\0, import-error/' \
- pylint/test/functional/deprecated_module_py36.py || die
- sed -i -e 's/^# pylint:.*/\0, wrong-import-order/' \
- pylint/test/functional/generated_members.py || die
- sed -i -e 's/test_good_comprehension_checks/_&/' \
- pylint/test/functional/using_constant_test.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # selection of straight html triggers a trivial annoying bug, we skirt it
- use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml
-}
-
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- doman man/{pylint,pyreverse}.1
- if use examples ; then
- docinto examples
- dodoc -r examples/.
- fi
- use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- # Optional dependency on "tk" USE flag would break support for Jython.
- optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." 'dev-lang/python[tk]'
-}