summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-31 07:37:43 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-31 08:21:00 +0200
commitdc7c286a123b14dda1e3330c3f24ec75adce0ec3 (patch)
tree46453cf8ccb21fd85c080527ae7df4492d24e3db /dev-python/pylint
parentdev-python/ipywidgets: Remove old (diff)
downloadgentoo-dc7c286a123b14dda1e3330c3f24ec75adce0ec3.tar.gz
gentoo-dc7c286a123b14dda1e3330c3f24ec75adce0ec3.tar.bz2
gentoo-dc7c286a123b14dda1e3330c3f24ec75adce0ec3.zip
dev-python/pylint: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/files/pylint-2.4.4-no-pytest-runner.patch12
-rw-r--r--dev-python/pylint/files/pylint-2.4.4-tests.patch13
-rw-r--r--dev-python/pylint/pylint-2.4.4-r1.ebuild58
4 files changed, 0 insertions, 84 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 4c40eb2364a0..2623be7a0b67 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,2 +1 @@
-DIST pylint-2.4.4.tar.gz 646113 BLAKE2B d62b66b056e01cc13e90f45ff4a11f94983e0b9b42b9a05e5c7b7385280000d15ead9a282e7eea31a8ee6a24ffe539576a6e9bd40dc4d89093263da99029123b SHA512 835e0687ebc76c530e0042c5a5188b8aedab446531f621627e990cbeb37ab6ecc8de0f8c6ab171abaa63488e049e8d7782958461421f9a4127435f56b6d2ed0b
DIST pylint-2.5.3.tar.gz 684449 BLAKE2B 7b494f5334376ff571fd8971851198d037e87c5be83d0123fcb108701489769785164bb077eb10b4851c89b82dadc40c510186eaf03be1621c4d78c79dffbceb SHA512 03fcd893d361b66794f17433e90df108099fee2eccb35507c7f61befb8db846f0242e5ce2b4ee63727c9cc780a376c3b93d5af3186f884a4fdaad68b224ed7d2
diff --git a/dev-python/pylint/files/pylint-2.4.4-no-pytest-runner.patch b/dev-python/pylint/files/pylint-2.4.4-no-pytest-runner.patch
deleted file mode 100644
index 0d668d01cdc9..000000000000
--- a/dev-python/pylint/files/pylint-2.4.4-no-pytest-runner.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 4d16b79b..b2a1b9e9 100644
---- a/setup.py
-+++ b/setup.py
-@@ -143,7 +143,6 @@ def install(**kwargs):
- extras_require=extras_require,
- test_suite="test",
- python_requires=">=3.5.*",
-- setup_requires=["pytest-runner"],
- tests_require=["pytest"],
- **kwargs
- )
diff --git a/dev-python/pylint/files/pylint-2.4.4-tests.patch b/dev-python/pylint/files/pylint-2.4.4-tests.patch
deleted file mode 100644
index b11ecb7c505b..000000000000
--- a/dev-python/pylint/files/pylint-2.4.4-tests.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/tests/unittest_lint.py b/tests/unittest_lint.py
-index 4f942cd0..d54008bf 100644
---- a/tests/unittest_lint.py
-+++ b/tests/unittest_lint.py
-@@ -792,7 +792,7 @@ def test_filename_with__init__(init_linter):
- messages = reporter.messages
- assert len(messages) == 0
-
--
-+@pytest.mark.skip("known failure, see https://github.com/PyCQA/pylint/issues/3198")
- def test_by_module_statement_value(init_linter):
- """Test "statement" for each module analized of computed correctly."""
- linter = init_linter
diff --git a/dev-python/pylint/pylint-2.4.4-r1.ebuild b/dev-python/pylint/pylint-2.4.4-r1.ebuild
deleted file mode 100644
index dea212ba1bc5..000000000000
--- a/dev-python/pylint/pylint-2.4.4-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-# entry_points is added via **kwargs in a dict
-_DISTUTILS_SETUPTOOLS_WARNED=1
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="https://www.logilab.org/project/pylint
- https://pypi.org/project/pylint/
- https://github.com/pycqa/pylint"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 sparc x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/astroid-2.3.3[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- dev-python/mccabe[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/six[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
- "${FILESDIR}/${PN}-2.4.4-no-pytest-runner.patch"
- "${FILESDIR}/${PN}-2.4.4-tests.patch"
-)
-
-distutils_enable_sphinx doc
-distutils_enable_tests pytest
-
-python_install_all() {
- doman man/{pylint,pyreverse}.1
- if use examples ; then
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- # Optional dependency on "tk" USE flag would break support for Jython.
- optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." 'dev-lang/python[tk]'
-}