summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-10-13 13:58:38 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-10-13 18:44:13 +0200
commitdefb45b91249091f02eee56e1a194ed2128e2553 (patch)
tree5ac82bfbffd880a58e70483929a4f2f45579d4da /dev-python/pylint
parentkde-plasma/plasma-disks: add ~ppc64 keyword, bug #748453 (diff)
downloadgentoo-defb45b91249091f02eee56e1a194ed2128e2553.tar.gz
gentoo-defb45b91249091f02eee56e1a194ed2128e2553.tar.bz2
gentoo-defb45b91249091f02eee56e1a194ed2128e2553.zip
dev-python/pylint: bump to 2.6.0
* Remove now unnecessary _DISTUTILS_SETUPTOOLS_WARNED=1 workaround. * Remove unnecessary pytest-runner removal (the logic was improved so it isn't added to all setup.py commands). * Add upper bounds to dependencies. * Don't compress examples. * Fix doc build. Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.6.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 2623be7a0b67..099f297e9dee 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1 +1,2 @@
DIST pylint-2.5.3.tar.gz 684449 BLAKE2B 7b494f5334376ff571fd8971851198d037e87c5be83d0123fcb108701489769785164bb077eb10b4851c89b82dadc40c510186eaf03be1621c4d78c79dffbceb SHA512 03fcd893d361b66794f17433e90df108099fee2eccb35507c7f61befb8db846f0242e5ce2b4ee63727c9cc780a376c3b93d5af3186f884a4fdaad68b224ed7d2
+DIST pylint-2.6.0.tar.gz 680289 BLAKE2B f7d4159478f667a3234beefd148857f26c8f7ea3aae3bfa70fa06fe2a8d86fcf22a0727a9fa5d8fc3de4aa0bb7a4d6e13bf68029f359122762d1e0d24a0b715b SHA512 02881fe14401bbe946618ef947c8db320a6c8dd93626402260d60468538ce67b61d1e8b921bfb1a6020514dd392e9b0021c97ddb60b45866c2d2241224f93f08
diff --git a/dev-python/pylint/pylint-2.6.0.ebuild b/dev-python/pylint/pylint-2.6.0.ebuild
new file mode 100644
index 000000000000..3f3e19709ba7
--- /dev/null
+++ b/dev-python/pylint/pylint-2.6.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Not ready for Python 3.9 yet: https://github.com/PyCQA/pylint/issues/3895
+PYTHON_COMPAT=( python3_{6..8} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="https://www.logilab.org/project/pylint
+ https://pypi.org/project/pylint/
+ https://github.com/pycqa/pylint"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+# Mirror requirements from pylint/__pkginfo__.py
+RDEPEND="
+ >=dev-python/astroid-2.4.0[${PYTHON_USEDEP}]
+ <=dev-python/astroid-2.5[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
+ "${FILESDIR}/${PN}-2.5.3-tests.patch"
+)
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # we don't want to run the benchmarking tests
+ rm -f tests/benchmark/test_baseline_benchmarks.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ doman man/{pylint,pyreverse}.1
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ # Optional dependency on "tk" USE flag would break support for Jython.
+ optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." 'dev-lang/python[tk]'
+}