summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-16 09:15:59 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-16 09:30:09 +0100
commit949bd00aafc84104dec2f1b63e468d6c1e3a98d2 (patch)
tree76a98cea0070f18d86df85b7260550896a9bf237 /dev-python/pyls-spyder
parentdev-python/pylint: Bump to 2.6.1 (diff)
downloadgentoo-949bd00aafc84104dec2f1b63e468d6c1e3a98d2.tar.gz
gentoo-949bd00aafc84104dec2f1b63e468d6c1e3a98d2.tar.bz2
gentoo-949bd00aafc84104dec2f1b63e468d6c1e3a98d2.zip
dev-python/pyls-spyder: Bump to 0.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyls-spyder')
-rw-r--r--dev-python/pyls-spyder/Manifest1
-rw-r--r--dev-python/pyls-spyder/pyls-spyder-0.3.2.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyls-spyder/Manifest b/dev-python/pyls-spyder/Manifest
index cb1055aa495b..9199514a868b 100644
--- a/dev-python/pyls-spyder/Manifest
+++ b/dev-python/pyls-spyder/Manifest
@@ -1 +1,2 @@
DIST pyls-spyder-0.3.0-gh.tar.gz 8545 BLAKE2B fe2ec3ca6a4440bb9112970550a096389a0969eea9f0cdd631110c19358ac387a97902cc21ee61c8961ef2ee020689c30f7c86f6448bbb40258d730b3cf79cbe SHA512 94ce684d8c7fdb8ece003c1965a001bd745a38086f382e0185f6750edb3103998165a5e2554f065d6364409e5438272e5c256b7b756b971f61f1dd5cbcf3d503
+DIST pyls-spyder-0.3.2-gh.tar.gz 8781 BLAKE2B ac24e0433c2e5ba43274d6266bc7532e7a1f1b0c3c34b9acfe10e5c7d789937536e81c4b19f96090f32d34c932529c0f4c23b49d2b01e7a0b628f8c2dd6f7611 SHA512 c08910ebaf161ceb712f273f054add1f3a202684b001d8d95650555bd67fa5675b3fef9e3d62d0d1b9da0f5adfeae9ff0fbfee44e4362856550d77582dbc6e95
diff --git a/dev-python/pyls-spyder/pyls-spyder-0.3.2.ebuild b/dev-python/pyls-spyder/pyls-spyder-0.3.2.ebuild
new file mode 100644
index 000000000000..513608b147d5
--- /dev/null
+++ b/dev-python/pyls-spyder/pyls-spyder-0.3.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spyder extensions for the python language server"
+HOMEPAGE="https://github.com/spyder-ide/pyls-spyder
+ https://pypi.org/project/pyls-spyder/"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}-gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/python-language-server-0.36.2[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/mock )"
+
+distutils_enable_tests pytest