summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-05-02 17:29:29 -0700
committerZac Medico <zmedico@gentoo.org>2017-05-02 17:32:30 -0700
commit6c53d943744dd2ea3c9371c802f32e0af82fbb11 (patch)
treece7596dfea7ea2fb44fdd513474e6ea822bfab6e /dev-python/pympler/pympler-0.5.ebuild
parentdev-python/pympler: version bump to 0.4.3 (diff)
downloadgentoo-6c53d943744dd2ea3c9371c802f32e0af82fbb11.tar.gz
gentoo-6c53d943744dd2ea3c9371c802f32e0af82fbb11.tar.bz2
gentoo-6c53d943744dd2ea3c9371c802f32e0af82fbb11.zip
dev-python/pympler: version bump to 0.5
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/pympler/pympler-0.5.ebuild')
-rw-r--r--dev-python/pympler/pympler-0.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pympler/pympler-0.5.ebuild b/dev-python/pympler/pympler-0.5.ebuild
new file mode 100644
index 000000000000..e9bf81fe01b4
--- /dev/null
+++ b/dev-python/pympler/pympler-0.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="Pympler"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Memory profiling for Python applications"
+HOMEPAGE="https://code.google.com/p/pympler/ https://pypi.python.org/pypi/Pympler https://github.com/pympler/pympler"
+SRC_URI="https://github.com/pympler/pympler/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# The PyPi tarball is missing the documentation
+#SRC_URI="mirror://pypi/P/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/bottle[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND} )"
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ sphinx-build -b html doc/{source,html} || die
+ fi
+}
+
+python_test() {
+ esetup.py try
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+}