summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pymssql
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pymssql')
-rw-r--r--dev-python/pymssql/Manifest1
-rw-r--r--dev-python/pymssql/metadata.xml11
-rw-r--r--dev-python/pymssql/pymssql-1.0.2-r1.ebuild26
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pymssql/Manifest b/dev-python/pymssql/Manifest
new file mode 100644
index 000000000000..541e3091d6d2
--- /dev/null
+++ b/dev-python/pymssql/Manifest
@@ -0,0 +1 @@
+DIST pymssql-1.0.2.tar.gz 175469 SHA256 c8befb3ec227fb3d1141558ddb1590549a493b677fa2fc85ee3e8dc9ad9a4f7b SHA512 6e9a2d26f2cc33bac093f2a2a41771aa41ba336413076c793137558c05e48cea7409f74f35530939b36a708cc47c66ec0dc765a768bd5f857642553568fe859e WHIRLPOOL 7ef0cfe36de73f26df8edb48eacd4bacac8dc847aee55387e6328c4688678969c6f6b0405552af8c7284e65fa3953f9f807357a4bea8bff88cc395a6a9edb5ef
diff --git a/dev-python/pymssql/metadata.xml b/dev-python/pymssql/metadata.xml
new file mode 100644
index 000000000000..6fd34d4822e8
--- /dev/null
+++ b/dev-python/pymssql/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>lordvan@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">pymssql</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pymssql/pymssql-1.0.2-r1.ebuild b/dev-python/pymssql/pymssql-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..7c2c58a6ab7b
--- /dev/null
+++ b/dev-python/pymssql/pymssql-1.0.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple MSSQL python extension module"
+HOMEPAGE="http://pymssql.sourceforge.net/ http://code.google.com/p/pymssql/ http://pypi.python.org/pypi/pymssql"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+
+DEPEND=">=dev-db/freetds-0.63[mssql]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}"
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}