summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-17 14:38:26 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-17 14:38:26 +0100
commit77f7cc28262211293c8df962146c27bb726b699d (patch)
tree9d485f238ba388d606d97e057e8550242e58c751 /dev-python/pyopencl
parentdev-python/fido2: drop 0.8.1 (diff)
downloadgentoo-77f7cc28262211293c8df962146c27bb726b699d.tar.gz
gentoo-77f7cc28262211293c8df962146c27bb726b699d.tar.bz2
gentoo-77f7cc28262211293c8df962146c27bb726b699d.zip
dev-python/pyopencl: add 2021.2.9
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest1
-rw-r--r--dev-python/pyopencl/pyopencl-2021.2.9.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 6cba7f1e930c..3ad6fec049a6 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1 +1,2 @@
DIST pyopencl-2021.2.6.tar.gz 450194 BLAKE2B be9d0bf653f77d33a4337deab9189a5a9031ff50526444283c6fb9f8625d0451cb211ff703b5eb86c18beebb973f8f7a7cc93da3efc6bb4e95cd533d633fde93 SHA512 b7bea4903a34104c538545c611554c1651ae7a94ee56d8c7129a88a9e547911fac085617b4238fac33534c9b981bcfdb9fabd716456a86fa428cfd42d9cb128c
+DIST pyopencl-2021.2.9.tar.gz 451109 BLAKE2B a4b9b1ee1bd4f42742aa2de3acb3f5fe54771905f15dc002327a6669bf460c825c81729403df0b98537deb91ca9d0fa8dd30dd8d7e718fcc23a256b6a797484b SHA512 557bdf20df97090557f441f47b31d5b2878341fe670a4e64a563d8a464fdd5915ece651103ed17396248ab174b1895f4841e5b7ac803b8bf6286266e2c4366d6
diff --git a/dev-python/pyopencl/pyopencl-2021.2.9.ebuild b/dev-python/pyopencl/pyopencl-2021.2.9.ebuild
new file mode 100644
index 000000000000..95577e0b236f
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2021.2.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl"
+
+DEPEND=">=virtual/opencl-2"
+RDEPEND="${DEPEND}
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
+# libglvnd is only needed for the headers
+BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
+ opengl? ( media-libs/libglvnd )"
+
+# The test suite fails if there are no OpenCL platforms available, and
+# even if there is one (which requires the presence of both an OpenCL
+# runtime *and* hardware supported by it - simply emerging any runtime
+# is not enough) the vast majority of tests end up skipped because by
+# default the portage user hasn't got sufficient privileges to talk
+# to the GPU.
+RESTRICT="test"
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}