summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-15 20:06:50 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-15 20:16:51 +0100
commitc730b9d92245c533f182c15be6f1fca08f5eeada (patch)
tree64e30d510304d4198a1500bf0d2e066e0e037b16 /dev-python/pyopencl
parentvirtual/pypy3: Fix slot in 7.3.0_rc1 (diff)
downloadgentoo-c730b9d92245c533f182c15be6f1fca08f5eeada.tar.gz
gentoo-c730b9d92245c533f182c15be6f1fca08f5eeada.tar.bz2
gentoo-c730b9d92245c533f182c15be6f1fca08f5eeada.zip
dev-python/pyopencl: Drop unmaintained -9999
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/pyopencl-9999.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/pyopencl/pyopencl-9999.ebuild b/dev-python/pyopencl/pyopencl-9999.ebuild
deleted file mode 100644
index 8055a67ac261..000000000000
--- a/dev-python/pyopencl/pyopencl-9999.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1 git-2
-
-EGIT_REPO_URI="https://git.tiker.net/trees/pyopencl.git"
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="https://mathema.tician.de/software/pyopencl
- https://pypi.org/project/pyopencl/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="examples opengl"
-
-RDEPEND=">=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- >=dev-python/pytools-9999[${PYTHON_USEDEP}]
- >=virtual/opencl-0-r1"
-DEPEND="${RDEPEND}"
-
-src_configure()
-{
- local myconf=()
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "${PYTHON}" configure.py \
- --boost-compiler=gcc \
- --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
- --no-use-shipped-boost \
- "${myconf[@]}"
-}
-
-python_install_all() {
- if use examples; then
- local EXAMPLES=( examples/. )
- einfo "Some of the examples provided by this package require dev-python/matplotlib."
- fi
- distutils-r1_python_install_all
-}