summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-18 07:49:58 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-18 08:27:08 +0100
commitaad8eb10d40e28ca1b81d8187d3a85ea5586a898 (patch)
treed843f547adc9c4dc5fbc82edf8d4248fff0617e4 /dev-python/pyopenssl
parentdev-python/pyhamcrest: Switch to distutils_enable_sphinx (diff)
downloadgentoo-aad8eb10d40e28ca1b81d8187d3a85ea5586a898.tar.gz
gentoo-aad8eb10d40e28ca1b81d8187d3a85ea5586a898.tar.bz2
gentoo-aad8eb10d40e28ca1b81d8187d3a85ea5586a898.zip
dev-python/pyopenssl: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/Manifest2
-rw-r--r--dev-python/pyopenssl/pyopenssl-17.5.0.ebuild67
-rw-r--r--dev-python/pyopenssl/pyopenssl-18.0.0.ebuild68
3 files changed, 0 insertions, 137 deletions
diff --git a/dev-python/pyopenssl/Manifest b/dev-python/pyopenssl/Manifest
index 063275bd3eeb..7b91c85c05e3 100644
--- a/dev-python/pyopenssl/Manifest
+++ b/dev-python/pyopenssl/Manifest
@@ -1,4 +1,2 @@
-DIST pyOpenSSL-17.5.0.tar.gz 170870 BLAKE2B e8b8986a7c5475ac3898df4877a8be86db359af79e1718bad85149440cff543c501ee23eb369270d2c539a9e3f4e13165ea87b858ef6916ee79ca6e49f6e5370 SHA512 f194662b5842f1e3a4fcb910b9f2e6482d1dcdf834f306acc3dd6d9723f65038f7bff550248fa6268d90c839c9d9e8248bb6c7d399495fe6aed25291b93ece86
-DIST pyOpenSSL-18.0.0.tar.gz 167296 BLAKE2B 3a9c8db02e92858353389508d9791d2ff0b07b54150d27a513b4c26ef62899167d184702cd8ac3a9fb5be120a92e31259ce265a400513de4622c30b1269ecd9f SHA512 7106d4116243a164c1f458ad495564c2cf3a46b4b0fbb1d452b4174ead4409bc9c783c3a4674231ed3c26ecf588077b01dadbdefe033d5e7251a61531c6f6c15
DIST pyOpenSSL-19.0.0.tar.gz 168551 BLAKE2B 762d3358b3cc4f1e088e9464ac079e5212c537d25691e51edb3255a192c42276506c758ecf16eff999082bfd05aeb92a37741338d92036d2149b87c95008db05 SHA512 a7e12bf5be725ccebd1223d567a9b9e8bd35f79cbf3a0409108fa6f00e10ab137dd6876369e9dede02b2abc7d700786cc905532ca5c31b6e246f6df8b24e2818
DIST pyOpenSSL-19.1.0.tar.gz 160510 BLAKE2B e6e39f860221a2696aa3fa32ac89ed48e34b18e4accc366a86264d943a15a1b00ba1a0d8349550d1775d25836aa5d214e1e3fe4ec0a9c0f6d5ab00cd9fede633 SHA512 4acd96f287d72eb11bd812697d28cd6eb6a96a4653248b65f967187830a6b17cc1254775a18a3405469f3d45abdae6f02d165f2f35f035f3174c2826fba82916
diff --git a/dev-python/pyopenssl/pyopenssl-17.5.0.ebuild b/dev-python/pyopenssl/pyopenssl-17.5.0.ebuild
deleted file mode 100644
index 00425f8df5f1..000000000000
--- a/dev-python/pyopenssl/pyopenssl-17.5.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-MY_PN=pyOpenSSL
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python interface to the OpenSSL library"
-HOMEPAGE="
- http://pyopenssl.sourceforge.net/
- https://launchpad.net/pyopenssl
- https://pypi.org/project/pyOpenSSL/
-"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.1.4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? (
- virtual/python-cffi[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.0.1[${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
- # Requires network access
- sed -i -e 's/test_set_default_verify_paths/_&/' tests/test_ssl.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- TZ=UTC py.test -v || die "Testing failed with ${EPYTHON}" # Fixes bug #627530
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- if use examples ; then
- docinto examples
- dodoc -r examples/*
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyopenssl/pyopenssl-18.0.0.ebuild b/dev-python/pyopenssl/pyopenssl-18.0.0.ebuild
deleted file mode 100644
index d3a31ab8b263..000000000000
--- a/dev-python/pyopenssl/pyopenssl-18.0.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-MY_PN=pyOpenSSL
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python interface to the OpenSSL library"
-HOMEPAGE="
- http://pyopenssl.sourceforge.net/
- https://launchpad.net/pyopenssl
- https://pypi.org/project/pyOpenSSL/
-"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.2.1[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? (
- virtual/python-cffi[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.0.1[${PYTHON_USEDEP}]
- )"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
- # Requires network access
- sed -i -e 's/test_set_default_verify_paths/_&/' tests/test_ssl.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- TZ=UTC py.test -v || die "Testing failed with ${EPYTHON}" # Fixes bug #627530
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- if use examples ; then
- docinto examples
- dodoc -r examples/*
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}