summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-10-16 21:35:00 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-10-16 21:35:00 +0200
commitcb26b30a4eef99c6098f74a7963911ef8ca0c23f (patch)
treeba51af31f4671bcca32e97d9f43520ceac805947 /dev-python/pyotherside/pyotherside-1.5.3.ebuild
parentwww-apache/passenger: Fix building with USE=-apache2, bug 626988 (diff)
downloadgentoo-cb26b30a4eef99c6098f74a7963911ef8ca0c23f.tar.gz
gentoo-cb26b30a4eef99c6098f74a7963911ef8ca0c23f.tar.bz2
gentoo-cb26b30a4eef99c6098f74a7963911ef8ca0c23f.zip
dev-python/pyotherside: Version bump to 1.5.3
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-python/pyotherside/pyotherside-1.5.3.ebuild')
-rw-r--r--dev-python/pyotherside/pyotherside-1.5.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyotherside/pyotherside-1.5.3.ebuild b/dev-python/pyotherside/pyotherside-1.5.3.ebuild
new file mode 100644
index 000000000000..4893f2c24289
--- /dev/null
+++ b/dev-python/pyotherside/pyotherside-1.5.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit qmake-utils python-single-r1
+
+DESCRIPTION="Asynchronous Python 3 Bindings for Qt 5"
+HOMEPAGE="https://github.com/thp/pyotherside http://thp.io/2011/pyotherside"
+SRC_URI="https://github.com/thp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ "
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e "s/qtquicktests//" pyotherside.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}