summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-31 14:06:05 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-31 14:09:38 +0100
commit32723c0bdd7b2882f30d0f53c6fdfafd8f90940b (patch)
tree2383a8968bb54f2764383efb17743cd800e9de48 /dev-python/pyparsing
parentdev-python/xonsh: Version Bump (diff)
downloadgentoo-32723c0bdd7b2882f30d0f53c6fdfafd8f90940b.tar.gz
gentoo-32723c0bdd7b2882f30d0f53c6fdfafd8f90940b.tar.bz2
gentoo-32723c0bdd7b2882f30d0f53c6fdfafd8f90940b.zip
dev-python/pyparsing: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyparsing')
-rw-r--r--dev-python/pyparsing/Manifest1
-rw-r--r--dev-python/pyparsing/pyparsing-2.0.7.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyparsing/Manifest b/dev-python/pyparsing/Manifest
index 54740a41d9bd..06d8c7b29f5a 100644
--- a/dev-python/pyparsing/Manifest
+++ b/dev-python/pyparsing/Manifest
@@ -3,3 +3,4 @@ DIST pyparsing-2.0.3.tar.gz 1462653 SHA256 06e729e1cbf5274703b1f47b6135ed8335999
DIST pyparsing-2.0.4.tar.gz 1140009 SHA256 c43c9f1395975bf2b032c20e6b149d6b698cdabf9291079bcaf0131709e95f59 SHA512 021d3610ead6b864b1e0227b6cad2393aae0c1f38a44c09dd7ac33d05be30cb4c75176a33ebd8c44e87ed9d54b58aaf27fab7ac8f3cdcb3ce4418b5b0d586b01 WHIRLPOOL 0fa3fe631c5c6fc79fb13f029fe8a32bd9651fd663e915c5be394225bcb1ea1f199d3edc2294e7a4b0732590e7a0cc3053effca9aa20155ca69d4c3908019e6d
DIST pyparsing-2.0.5.tar.gz 1140072 SHA256 58756bf33e989d84ac72142e4ca558cf10c778a3233edb0a86632f271409ba9e SHA512 203c4520378302434078b49467369ee0ae70ef4807ca16b8e0ca361dbc3f555806e5e07f9e5005eec34452144b528ed0480f8892b1c61bae83512baa4e74b56e WHIRLPOOL 0da95e0d61a877669ff0f586e3688b0f8444baa5b857fdea8bb758b52af1ea8d6709effe2d1df031bf7d5940fb3b65582f44ca750adedaae12a36d5af105b6a6
DIST pyparsing-2.0.6.tar.gz 1140849 SHA256 aea69042752ad7e9c436eea6ae5d40e73642e27f50edb6da4a2532030ef532da SHA512 3722198efc98f6ffc124fa012f6ef23ec840ccc2280922dcb35b05c1e78cdc40f1057be0f364732d20fb0dd25897776a15625ceadee14f6800d67b6d180b42f1 WHIRLPOOL c6228050452d4297bcb77326972b5ea5c671ee264ce8ebba1ceb115f8ca84e099d94a6db43a1dafef761e26bbf8cab96d46602e116c1d03607ab1860d907c233
+DIST pyparsing-2.0.7.tar.gz 1141457 SHA256 2ce0db3c70ec0413603d4aea389e4ece34ff93c265649b1c5c7d56e3c2cf19c4 SHA512 1430262481e97357b0b376db7f938c10dde4514f8f70332252af2de8aee9a0b79cb7a00435c7c8baae2dd1ed9c5d06602cd1ef9bfd6d2f5f30fed1a96c32fe78 WHIRLPOOL e306804b0116d40990f53e1c97188b4dd0163f932b92eddd1ece8f078911f52cb34e06cc186b77ea0a4ce4cef5bf4a804b916fcca210000322df368263be6a13
diff --git a/dev-python/pyparsing/pyparsing-2.0.7.ebuild b/dev-python/pyparsing/pyparsing-2.0.7.ebuild
new file mode 100644
index 000000000000..ef7c5b117177
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-2.0.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="http://pyparsing.wikispaces.com/ https://pypi.python.org/pypi/pyparsing"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples"
+
+RDEPEND="!dev-python/pyparsing:py2 !dev-python/pyparsing:py3"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# no contained in the tarball
+RESTRICT=test
+
+python_install_all() {
+ local HTML_DOCS=( HowToUsePyparsing.html )
+ if use doc; then
+ HTML_DOCS+=( htmldoc/. )
+ dodoc docs/*.pdf
+ fi
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ ${PYTHON} unitTests.py || die
+}