summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-11-15 18:46:41 +0100
committerJeroen Roovers <jer@gentoo.org>2019-11-15 18:47:34 +0100
commit472132346457d1dee506eef87ec635ff75c5632a (patch)
tree70f791e2e201457b4bb7c9f8bb5c83d016cfbe8a /dev-python/pyparted
parentdev-python/pyparted: Old (diff)
downloadgentoo-472132346457d1dee506eef87ec635ff75c5632a.tar.gz
gentoo-472132346457d1dee506eef87ec635ff75c5632a.tar.bz2
gentoo-472132346457d1dee506eef87ec635ff75c5632a.zip
dev-python/pyparted: Add live ebuild
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/pyparted-999999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pyparted/pyparted-999999.ebuild b/dev-python/pyparted/pyparted-999999.ebuild
new file mode 100644
index 000000000000..f05348d00058
--- /dev/null
+++ b/dev-python/pyparted/pyparted-999999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://github.com/rhinstaller/pyparted/"
+EGIT_REPO_URI="https://github.com/rhinstaller/pyparted/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ >=sys-block/parted-3.1
+ dev-python/decorator[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+RESTRICT="test"