summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-11 17:05:13 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-11 17:05:24 +0100
commit7324627843298754cf618a5a960c09cc380c1f2e (patch)
tree32abaf0a93a9c9725c2650fe9bb7a72185b24018 /dev-python/pyparted
parentnet-print/hplip: arm stable wrt bug #706146 (diff)
downloadgentoo-7324627843298754cf618a5a960c09cc380c1f2e.tar.gz
gentoo-7324627843298754cf618a5a960c09cc380c1f2e.tar.bz2
gentoo-7324627843298754cf618a5a960c09cc380c1f2e.zip
dev-python/pyparted: Version 3.11.4
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/Manifest1
-rw-r--r--dev-python/pyparted/pyparted-3.11.4.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyparted/Manifest b/dev-python/pyparted/Manifest
index e02789d7a13a..c7292c4403ac 100644
--- a/dev-python/pyparted/Manifest
+++ b/dev-python/pyparted/Manifest
@@ -1,3 +1,4 @@
DIST pyparted-3.10.7.tar.gz 99879 BLAKE2B f2d03415ec7623fbe25aeab70e53646aa5e576e9f20ac41ffe6c859be9572874579f5720b8d05191107f4143e2c6dd14d83a05798a345fa0ed8a81ce2634f599 SHA512 c57fed2a8d04511b12891fd59b6dd6840439aada7e5ebeab14a56e6e4f201c249046ee87d9d25af1b3f02960994efb0a2973f25928a9df85d48bbd1bc196ab07
DIST pyparted-3.11.2.tar.gz 101318 BLAKE2B 0c79535d6f3a269d5dfdd6c31ec80569d8c7432cd058f90999ebfd61ef727762a395d902539c49744108e92ba1a351c1ec939c02188869bed6c808551a843f92 SHA512 de6e7387e3eb9c9cb11e01f475d2749d2ce22ec2f11386df20cafcf83f7e431828f2db936f29c717e42694ff390a592598893633156a21aa7c8d5700a3c9ece9
DIST pyparted-3.11.3.tar.gz 105305 BLAKE2B 271d0ed91c187c66219f06e91def5e868d81494241a2e9137676162ffa388523f5cccb3ec6dfed655cb59da1ca56e7fde3bb9fafa227b86d8f7b279759fe237b SHA512 b10a89d076a27a074d606101dccb62176299dd8f9da75a5a4bf9c8a6683d2873b649d948736e991e4cfa21d43a54e7d2934da8e539ce8626ae5fd47e892ae286
+DIST pyparted-3.11.4.tar.gz 105345 BLAKE2B 55d41d44e286b6b737aeb65880996f8b69c99286cea672512a2f64118f346b38436de8e15fee45bf5ba8151155142a995e310549c6f3d47600351760d514dd3d SHA512 d0603235a0cfce6c93520eb8577f47f51c76016c396ed85cfa57777dfe0cf06c32605c91d7d0252e8910025347e1d3ebdec8c77d4b9db13ed380b7fdf0113de6
diff --git a/dev-python/pyparted/pyparted-3.11.4.ebuild b/dev-python/pyparted/pyparted-3.11.4.ebuild
new file mode 100644
index 000000000000..5dcdba1e16b1
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.11.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,8} )
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://github.com/rhinstaller/pyparted/"
+SRC_URI="https://github.com/rhinstaller/pyparted/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=sys-block/parted-3.1
+ dev-python/decorator[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+distutils_enable_tests unittest
+
+src_configure() {
+ append-cflags -fcommon
+ default
+}