summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-02-05 15:44:48 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-02-05 15:46:09 -0800
commitc7d5971f363858939b6792e13eb275f9d6565cf8 (patch)
tree3f1e45d42cb26ac324bd8ff0611df2028caaad9c /dev-python/pyparted
parentdev-qt/qtcore: stable 5.13.2-r2 for ppc, bug #707354 (diff)
downloadgentoo-c7d5971f363858939b6792e13eb275f9d6565cf8.tar.gz
gentoo-c7d5971f363858939b6792e13eb275f9d6565cf8.tar.bz2
gentoo-c7d5971f363858939b6792e13eb275f9d6565cf8.zip
dev-python/pyparted-3.11.3: Add py38, enable tests
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/pyparted-3.11.3.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/pyparted/pyparted-3.11.3.ebuild b/dev-python/pyparted/pyparted-3.11.3.ebuild
index 9412f7f7545e..5dcdba1e16b1 100644
--- a/dev-python/pyparted/pyparted-3.11.3.ebuild
+++ b/dev-python/pyparted/pyparted-3.11.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,8} )
inherit distutils-r1 flag-o-matic
DESCRIPTION="Python bindings for sys-block/parted"
@@ -21,7 +21,8 @@ DEPEND="
${RDEPEND}
virtual/pkgconfig
"
-RESTRICT="test"
+
+distutils_enable_tests unittest
src_configure() {
append-cflags -fcommon