summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-31 17:27:13 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-31 17:42:30 +0200
commit031559e03353f9a49a8640a75312915c54c5f6ca (patch)
tree264c639a95b6381d48f16cddb1683062ef66ac59 /dev-python/pyperclip
parentdev-python/colorama: Port to py39 (diff)
downloadgentoo-031559e03353f9a49a8640a75312915c54c5f6ca.tar.gz
gentoo-031559e03353f9a49a8640a75312915c54c5f6ca.tar.bz2
gentoo-031559e03353f9a49a8640a75312915c54c5f6ca.zip
dev-python/pyperclip: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyperclip')
-rw-r--r--dev-python/pyperclip/pyperclip-1.5.27.ebuild23
-rw-r--r--dev-python/pyperclip/pyperclip-1.7.0.ebuild3
2 files changed, 19 insertions, 7 deletions
diff --git a/dev-python/pyperclip/pyperclip-1.5.27.ebuild b/dev-python/pyperclip/pyperclip-1.5.27.ebuild
index 15e303b5c97d..f1298bc162c6 100644
--- a/dev-python/pyperclip/pyperclip-1.5.27.ebuild
+++ b/dev-python/pyperclip/pyperclip-1.5.27.ebuild
@@ -3,8 +3,8 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 python3_7)
-inherit distutils-r1
+PYTHON_COMPAT=( python2_7 python3_{6..8} )
+inherit distutils-r1 virtualx
DESCRIPTION="A cross-platform clipboard module for Python."
HOMEPAGE="https://github.com/asweigart/pyperclip"
@@ -13,7 +13,20 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm64 ~ppc64 x86"
-IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
+RDEPEND="
+ || (
+ x11-misc/xclip
+ x11-misc/xsel
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_copy_paste.py -vv ||
+ die "Tests fail on ${EPYTHON}"
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
diff --git a/dev-python/pyperclip/pyperclip-1.7.0.ebuild b/dev-python/pyperclip/pyperclip-1.7.0.ebuild
index 56aca177ce23..8ae4348d65c1 100644
--- a/dev-python/pyperclip/pyperclip-1.7.0.ebuild
+++ b/dev-python/pyperclip/pyperclip-1.7.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 virtualx
DESCRIPTION="A cross-platform clipboard module for Python."
@@ -14,7 +14,6 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~ppc64 sparc x86"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
|| (
x11-misc/xclip