summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pypgsql
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pypgsql')
-rw-r--r--dev-python/pypgsql/Manifest1
-rw-r--r--dev-python/pypgsql/metadata.xml8
-rw-r--r--dev-python/pypgsql/pypgsql-2.5.1-r1.ebuild32
-rw-r--r--dev-python/pypgsql/pypgsql-2.5.1.ebuild38
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/pypgsql/Manifest b/dev-python/pypgsql/Manifest
new file mode 100644
index 000000000000..4599a025d019
--- /dev/null
+++ b/dev-python/pypgsql/Manifest
@@ -0,0 +1 @@
+DIST pyPgSQL-2.5.1.tar.gz 152840 SHA256 498486f066f11a68f5b02a54ba5a008d01d507038c873bfd901c14d3f5ca18af SHA512 50fc6f9e44f17e116a9122ab010642850d6dcdcbecf8e0ee4c32182eadc593cde2b03aa3cc353cdcc5f79f6e4f7337e6b1250f3b98977b208a98aad282763ab3 WHIRLPOOL 55a21c648d8eeda53def823039f9021982b02ceaa0cac72384c113a1a2ce2a0fdccfa4697dad800d79adc161583cc1a1c281ad602483c7a43cf9952584176124
diff --git a/dev-python/pypgsql/metadata.xml b/dev-python/pypgsql/metadata.xml
new file mode 100644
index 000000000000..55c1d142df87
--- /dev/null
+++ b/dev-python/pypgsql/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="sourceforge">pypgsql</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pypgsql/pypgsql-2.5.1-r1.ebuild b/dev-python/pypgsql/pypgsql-2.5.1-r1.ebuild
new file mode 100644
index 000000000000..5e7fd4651c64
--- /dev/null
+++ b/dev-python/pypgsql/pypgsql-2.5.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P="pyPgSQL-${PV}"
+
+DESCRIPTION="Python Interface to PostgreSQL"
+HOMEPAGE="http://pypgsql.sourceforge.net/ http://pypi.python.org/pypi/pyPgSQL"
+SRC_URI="mirror://sourceforge/pypgsql/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-db/postgresql"
+RDEPEND="${DEPEND}
+ dev-python/egenix-mx-base[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pypgsql/pypgsql-2.5.1.ebuild b/dev-python/pypgsql/pypgsql-2.5.1.ebuild
new file mode 100644
index 000000000000..9ee38c06a858
--- /dev/null
+++ b/dev-python/pypgsql/pypgsql-2.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+
+inherit distutils
+
+MY_P="pyPgSQL-${PV}"
+
+DESCRIPTION="Python Interface to PostgreSQL"
+HOMEPAGE="http://pypgsql.sourceforge.net/ http://pypi.python.org/pypi/pyPgSQL"
+SRC_URI="mirror://sourceforge/pypgsql/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ia64 x86"
+IUSE=""
+
+DEPEND="dev-db/postgresql"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="Announce"
+PYTHON_MODNAME="pyPgSQL"
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}