summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-02 18:39:03 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-02 18:53:43 +0200
commitc17c855182a95738722d2e6470d01e6663c2e005 (patch)
tree644cbe486c1dcbe6433d8fc1296a29d038706391 /dev-python/pyproj/pyproj-1.9.4.ebuild
parentdev-python/pypgsql: Use append-cflags (diff)
downloadgentoo-c17c855182a95738722d2e6470d01e6663c2e005.tar.gz
gentoo-c17c855182a95738722d2e6470d01e6663c2e005.tar.bz2
gentoo-c17c855182a95738722d2e6470d01e6663c2e005.zip
dev-python/pyproj: Use append-cflags
drop old Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyproj/pyproj-1.9.4.ebuild')
-rw-r--r--dev-python/pyproj/pyproj-1.9.4.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/pyproj/pyproj-1.9.4.ebuild b/dev-python/pyproj/pyproj-1.9.4.ebuild
index 4078330458dd..57f70d65582d 100644
--- a/dev-python/pyproj/pyproj-1.9.4.ebuild
+++ b/dev-python/pyproj/pyproj-1.9.4.ebuild
@@ -3,9 +3,10 @@
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
DESCRIPTION="Python interface to PROJ.4 library"
HOMEPAGE="https://github.com/jswhit/pyproj"
@@ -16,7 +17,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
IUSE="doc"
-CFLAGS="${CFLAGS} -fno-strict-aliasing"
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ append-cflags -fno-strict-aliasing
+}
python_test() {
einfo "Testruns do not have regular unittest type tests, instead for test.py,"