summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-18 19:44:12 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-18 22:08:54 +0100
commit33087962d7f10f943c074655c67ea8dc9b591148 (patch)
tree6d70e14c2701d34040b14c92bc8bfbb85ece0b99 /dev-python/pyproj
parentdev-python/owslib: Drop 0.17.1-r1 (diff)
downloadgentoo-33087962d7f10f943c074655c67ea8dc9b591148.tar.gz
gentoo-33087962d7f10f943c074655c67ea8dc9b591148.tar.bz2
gentoo-33087962d7f10f943c074655c67ea8dc9b591148.zip
dev-python/pyproj: Drop 2.4.2-r1
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/pyproj')
-rw-r--r--dev-python/pyproj/Manifest1
-rw-r--r--dev-python/pyproj/files/pyproj-2.4.2-conftest.patch31
-rw-r--r--dev-python/pyproj/pyproj-2.4.2-r1.ebuild37
3 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/pyproj/Manifest b/dev-python/pyproj/Manifest
index 9ef79528f4d0..acbd64e22bb9 100644
--- a/dev-python/pyproj/Manifest
+++ b/dev-python/pyproj/Manifest
@@ -1,2 +1 @@
-DIST pyproj-2.4.2.tar.gz 463252 BLAKE2B aa80ee3052f42f0d49d02b1dfa3d1790e02fe6aa4092319ff8e827b0a341cff2cb4779891f74919c2b14781d841b3662154882b5f218a22b55ad79397f3eb4a7 SHA512 20f0a742ea5699a6d7a621e93157512478de69ba740bb7b0df46b6d5668f6db93b07e1fc0bf4d089362275ea8edddf3100a972a533ed8b6a0bc56a04a20d4ef9
DIST pyproj-2.6.1.post1.tar.gz 545482 BLAKE2B ba87cbbe93dad357c1fc4f333c7d3f02b632e6f2a00821b3875e73965f36fd7ea958f24705c125c3ae43dc8edac1b53a20578c46bc55bcbf335a9457d193d493 SHA512 43a885dbbf4ba54839c3b697d2582700e2b30172ef34acf6297b5e4ddba9b3148aeab83b3a515f1ce975898828c77ad457b6f6460e91083189f66a2fde6d77b7
diff --git a/dev-python/pyproj/files/pyproj-2.4.2-conftest.patch b/dev-python/pyproj/files/pyproj-2.4.2-conftest.patch
deleted file mode 100644
index 36946527b2b2..000000000000
--- a/dev-python/pyproj/files/pyproj-2.4.2-conftest.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/test/conftest.py
-+++ b/test/conftest.py
-@@ -0,0 +1,28 @@
-+import os
-+import shutil
-+import tempfile
-+
-+import pytest
-+
-+import pyproj
-+
-+
-+@pytest.fixture(scope="session")
-+def aoi_data_directory():
-+ """
-+ This is to ensure that the ntv2_0.gsb file is actually
-+ missing for the AOI tests.
-+ """
-+ data_dir = pyproj.datadir.get_data_dir()
-+ with tempfile.TemporaryDirectory() as tmpdir:
-+ tmp_data_dir = os.path.join(tmpdir, "proj")
-+ shutil.copytree(data_dir, tmp_data_dir)
-+ try:
-+ os.remove(os.path.join(str(tmp_data_dir), "ntv2_0.gsb"))
-+ except OSError:
-+ pass
-+ try:
-+ pyproj.datadir.set_data_dir(str(tmp_data_dir))
-+ yield
-+ finally:
-+ pyproj.datadir.set_data_dir(data_dir)
diff --git a/dev-python/pyproj/pyproj-2.4.2-r1.ebuild b/dev-python/pyproj/pyproj-2.4.2-r1.ebuild
deleted file mode 100644
index 40c39af68498..000000000000
--- a/dev-python/pyproj/pyproj-2.4.2-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# Python < 3.6 requires https://pypi.org/project/aenum/
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python interface to the PROJ library"
-HOMEPAGE="https://github.com/pyproj4/pyproj"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux"
-IUSE="doc"
-
-RDEPEND=">=sci-libs/proj-6.2.0:="
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- sci-libs/shapely[${PYTHON_USEDEP}]
- )"
-
-PATCHES=( "${FILESDIR}"/${P}-conftest.patch )
-
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
-distutils_enable_tests pytest
-
-python_test() {
- PROJ_LIB="${EPREFIX}/usr/share/proj" pytest -ra || die
-}