summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-18 08:48:15 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-18 08:53:43 +0200
commit96396a35cd33e0f07147af13ff4f47e490e80340 (patch)
tree257c0e561dd54f8441b767dccea82167889f1a6a /dev-python/pyproj
parentdev-python/GitPython: Remove yanked 3.1.23 (diff)
downloadgentoo-96396a35cd33e0f07147af13ff4f47e490e80340.tar.gz
gentoo-96396a35cd33e0f07147af13ff4f47e490e80340.tar.bz2
gentoo-96396a35cd33e0f07147af13ff4f47e490e80340.zip
dev-python/pyproj: Bump to 3.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyproj')
-rw-r--r--dev-python/pyproj/Manifest1
-rw-r--r--dev-python/pyproj/pyproj-3.2.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pyproj/Manifest b/dev-python/pyproj/Manifest
index 37dc0209afb0..7dbbc6ffc5be 100644
--- a/dev-python/pyproj/Manifest
+++ b/dev-python/pyproj/Manifest
@@ -1,3 +1,4 @@
DIST pyproj-3.0.1.tar.gz 168962 BLAKE2B 3271d604148c122f4dfdd68c4237e1911f30da7cc858128d644b6b6807c3e49450e0b42c385d37bbe1cfa5ab80d635e7f620d41bf5089af6b49a542eb9b3fcd0 SHA512 f5ae0ede1deaa93757cb98cc680d6e47a19b9f5c0ce5e357c2ecfe96f764ff59ec7285c606162da38573123d21f12f1df82354f1d2205149970af2d7d63c2689
DIST pyproj-3.1.0.tar.gz 182603 BLAKE2B d4e95f62b10b282e7bbfcb7a2059a11a489e53402cbb1760b7da73248dfc05de6be8ca820e55d34c9270eea38178f1fb934bd5ffc389833b3734b87b79991187 SHA512 21a5d08207676d8d9722cb5e3b13ed68f03b1a2aa034c20c61bb8dab5d204dd968ba9a3df1b0c43ed174e082725c7624efb75a0c9c3df920808cbcb44f4d170a
DIST pyproj-3.2.0.tar.gz 212708 BLAKE2B f880b8aade716e6137bcd4cc4c2d96946e2c7c735077f8707e37b3f174b2613f0281a48140a0154a21615423cd2e1ed70cea79916a04f4b9d84e958b6fe31795 SHA512 67eedd839d625f57accbabadee719030184a79f74185765da2b5610d73b8341435edc56d70d42d5a5d0ece0e22421742a327fe746761ec4f782a72d977306a74
+DIST pyproj-3.2.1.tar.gz 213342 BLAKE2B 141f64f33f399e1089009f8047b2541516dc84f2b2133f5e0de5cbaf5d5bef30197f556f630076725a4d78c4244011bf1a7c9a54114d6e166cbb9c10c468da05 SHA512 4ba5bd2d2356c06b711e53581665bdcad3faeb420258c7d4bbb5639784948842a3a6ee0f1f0f50363878c183c38a27063071f25594576eccca146ceb33107761
diff --git a/dev-python/pyproj/pyproj-3.2.1.ebuild b/dev-python/pyproj/pyproj-3.2.1.ebuild
new file mode 100644
index 000000000000..264aa18088e4
--- /dev/null
+++ b/dev-python/pyproj/pyproj-3.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface to the PROJ library"
+HOMEPAGE="https://github.com/pyproj4/pyproj"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+RDEPEND=">=sci-libs/proj-7.2.0:="
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests --install pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/test_datum.py
+ test/test_transformer.py::test_transform_wgs84_to_alaska
+ test/test_transformer.py::test_repr__conditional
+ test/test_transformer.py::test_transformer_group__unavailable
+ test/test_transformer.py::test_transformer_group__network_disabled
+ test/test_transformer.py::test_transformer_group__download_grids__directory
+ test/crs/test_crs.py::test_coordinate_operation_grids__alternative_grid_name
+ )
+
+ distutils_install_for_testing
+ cp -r test "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+ epytest --import-mode=append -m "not network" test
+}