summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-10 21:33:59 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-10 21:40:22 +0100
commit8b3c0b622cee195309cd0fa5c35d5b76a9425c27 (patch)
tree6f15232045626310e57c0837faa717a3654f5079 /dev-python/pyprotocols/pyprotocols-1.0_pre2306-r1.ebuild
parentdev-python/decoratortools: Port to EAPI 6 (diff)
downloadgentoo-8b3c0b622cee195309cd0fa5c35d5b76a9425c27.tar.gz
gentoo-8b3c0b622cee195309cd0fa5c35d5b76a9425c27.tar.bz2
gentoo-8b3c0b622cee195309cd0fa5c35d5b76a9425c27.zip
dev-python/pyprotocols: Port to EAPI 6
Bug: https://bugs.gentoo.org/show_bug.cgi?id=611216 Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-python/pyprotocols/pyprotocols-1.0_pre2306-r1.ebuild')
-rw-r--r--dev-python/pyprotocols/pyprotocols-1.0_pre2306-r1.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-python/pyprotocols/pyprotocols-1.0_pre2306-r1.ebuild b/dev-python/pyprotocols/pyprotocols-1.0_pre2306-r1.ebuild
index 628f002ad00a..8a8f9f0b4bdc 100644
--- a/dev-python/pyprotocols/pyprotocols-1.0_pre2306-r1.ebuild
+++ b/dev-python/pyprotocols/pyprotocols-1.0_pre2306-r1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
+
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 flag-o-matic eutils
+inherit distutils-r1 flag-o-matic
MY_PN="PyProtocols"
MY_P="${MY_PN}-${PV/_pre/a0dev_r}"
@@ -26,12 +27,14 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_PN}"
+PATCHES=( "${FILESDIR}"/SkipTests.patch )
DOCS=( CHANGES.txt README.txt UPGRADING.txt )
python_prepare_all() {
# Rm peripheral & rogue failing tests
rm -f src//protocols/tests/{test_twisted.py,test_zope.py} || die
- epatch "${FILESDIR}"/SkipTests.patch
+
+ distutils-r1_python_prepare_all
}
python_configure_all() {
@@ -39,6 +42,5 @@ python_configure_all() {
}
python_test() {
- esetup.py test && einfo "Tests passed under ${EPYTHON}" \
- || die "Tests failed under ${EPYTHON}"
+ esetup.py test || die "Tests failed under ${EPYTHON}"
}