summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-15 17:16:27 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-16 13:33:38 +0100
commitc6129a87a4f7589d97cca3280bc9c79e46037ca5 (patch)
treeb0fb8edc1f8ce07a9706655e1e8c0256a991ce20 /dev-python/pypy-bin
parentdev-python/pypy3: Fix mtimes between generated and source files (diff)
downloadgentoo-c6129a87a4f7589d97cca3280bc9c79e46037ca5.tar.gz
gentoo-c6129a87a4f7589d97cca3280bc9c79e46037ca5.tar.bz2
gentoo-c6129a87a4f7589d97cca3280bc9c79e46037ca5.zip
dev-python/pypy-bin: Fix mtimes between generated and source files
Ensure to preserve file mtimes while copying them from the source tree to the installation image. This ensures that the generated files are newer than source files, and that PyPy does not attempt to rewrite them at runtime.
Diffstat (limited to 'dev-python/pypy-bin')
-rw-r--r--dev-python/pypy-bin/pypy-bin-5.9.0-r2.ebuild (renamed from dev-python/pypy-bin/pypy-bin-5.9.0-r1.ebuild)2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/pypy-bin/pypy-bin-5.9.0-r1.ebuild b/dev-python/pypy-bin/pypy-bin-5.9.0-r2.ebuild
index b33c85d2d303..8c3b3d419da8 100644
--- a/dev-python/pypy-bin/pypy-bin-5.9.0-r1.ebuild
+++ b/dev-python/pypy-bin/pypy-bin-5.9.0-r2.ebuild
@@ -171,6 +171,8 @@ src_install() {
doexe pypy-c libpypy-c.so
pax-mark m "${ED%/}${dest}/pypy-c" "${ED%/}${dest}/libpypy-c.so"
insinto "${dest}"
+ # preserve mtimes to avoid obsoleting caches
+ insopts -p
doins -r include lib_pypy lib-python
dosym ../$(get_libdir)/pypy/pypy-c /usr/bin/pypy
dodoc README.rst