summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-15 13:23:34 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-15 13:23:58 +0200
commit76d8482bd7f496ca1b79204271e83b789eadd94a (patch)
tree29e4ce579e05d847259d4649870883c80db94c85 /dev-python/pypy3-bin
parentnet-dns/valtz: Version the distfile (diff)
downloadgentoo-76d8482bd7f496ca1b79204271e83b789eadd94a.tar.gz
gentoo-76d8482bd7f496ca1b79204271e83b789eadd94a.tar.bz2
gentoo-76d8482bd7f496ca1b79204271e83b789eadd94a.zip
dev-python/pypy3-bin: Rebuild no-sse2 x86 package
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypy3-bin')
-rw-r--r--dev-python/pypy3-bin/Manifest1
-rw-r--r--dev-python/pypy3-bin/pypy3-bin-7.1.1-r1.ebuild188
2 files changed, 189 insertions, 0 deletions
diff --git a/dev-python/pypy3-bin/Manifest b/dev-python/pypy3-bin/Manifest
index f8f5694c26c8..2ff35e7bb573 100644
--- a/dev-python/pypy3-bin/Manifest
+++ b/dev-python/pypy3-bin/Manifest
@@ -2,5 +2,6 @@ DIST pypy3-bin-7.1.1-amd64+bzip2+jit+ncurses.tar.lz 11031375 BLAKE2B e01ac298d3c
DIST pypy3-bin-7.1.1-amd64+bzip2+ncurses.tar.lz 6915836 BLAKE2B 0f3f2210e7f6e73872d32b2c01a911b52ad2a8c8987034709d9e4c72cfe11e422eea7b6522b19b3717876307d9fbbfbdfcc008dc2e3771dea083eeb61c202e6e SHA512 7fe6a19f56d7cdc142b368154e17af8936b8b730102c4a1c8a6b756a13b643d1375a51f45a0a3d345f7a8a23b75a81d35a6aa810129d231bf2091e156f69a914
DIST pypy3-bin-7.1.1-x86+bzip2+jit+ncurses+sse2.tar.lz 8540485 BLAKE2B a7de0db24e4bc56d54cbc03d618f8e08932e23a1fe5a1ab227600c244e222a6dae723c72fbd5cdd059c3e3f52bd355c4c9ee18506f6b39961bd1473358d35bd3 SHA512 f3355109bc073e220a33e8763c2d2ccf152d223d3850bb85aac71c19170ce4b118a84f258a829c486209f3c3014264384b158de17c9a0156c24afcf5b130a8e0
DIST pypy3-bin-7.1.1-x86+bzip2+ncurses+sse2.tar.lz 5523574 BLAKE2B 44f760842b0f232f7f5fb7a2fe3f60ff1f832dec3b0c16d1fd27ab36d09c12d6be8aa6727a880c3400506ea415317ddfb982439c1a581a03909099eeb6ea8cf6 SHA512 df664a7afa5bdd329d19046c81e362782c4f9358add2b7e54100df10a23434b9a341ec504ac1d49b2b017917937ab23ffd3cf723f86b65d7080789f795f5a4d3
+DIST pypy3-bin-7.1.1-x86+bzip2+ncurses.r1.tar.lz 5550959 BLAKE2B 72b1f84f0c70b07bd622b4d9ba67b165ce047037acc9a4fb46427b07db8793610f71dc389fc5cede209663c7d36750faf6247d5b6eb3be006c6cc58e4a94b0eb SHA512 3c522a9cf0e94aa8c14e9982a09231517c2c2b46e73a9c69bc6c43c44afefa3958de8879ac0fff2d43f8a0fc79117bdee645599d8e1d6a0def9806b44a4b1bc9
DIST pypy3-bin-7.1.1-x86+bzip2+ncurses.tar.lz 5545191 BLAKE2B 2afc40968977cd6956cb305a829811640e8437f0a811435a20ec694181286c94c820fd4148e3b6323a014ff391400d5265a7c1ee8b918c3db91ac02b44f3d585 SHA512 a1dad750491c5f524217986817a046c5c7a97b2b250a1d24b6a077d2d8067e249966cd331a5336fa2960a3d317c1aa83196c3e3b2f4a0734d79fe43cd9b55032
DIST pypy3.6-v7.1.1-src.tar.bz2 23171982 BLAKE2B be43528bc6f3e02d146016a4969bd8c7a9e880a3bd3b77f441aac6d22ef67700f71e0171ec000066bd2c0bd506db64af69d6b75b59a92222dd0353ee70e6629b SHA512 17e78f9c7080d597a6283d8e8247d1ca78f09a14ff221db8c3d90d255b5befc73102b317ca34a80979e544d5ee72f3e5e649f89d185a085f4cc15012da4d0473
diff --git a/dev-python/pypy3-bin/pypy3-bin-7.1.1-r1.ebuild b/dev-python/pypy3-bin/pypy3-bin-7.1.1-r1.ebuild
new file mode 100644
index 000000000000..453ae142dbd3
--- /dev/null
+++ b/dev-python/pypy3-bin/pypy3-bin-7.1.1-r1.ebuild
@@ -0,0 +1,188 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Test runner needs Python 2.
+PYTHON_COMPAT=( python2_7 pypy )
+inherit pax-utils python-any-r1 unpacker
+
+BINHOST="https://dev.gentoo.org/~mgorny/dist/pypy3-bin/${PV}"
+MY_P=pypy3.6-v${PV}
+
+DESCRIPTION="A fast, compliant alternative implementation of Python 3.6 (binary package)"
+HOMEPAGE="http://pypy.org/"
+SRC_URI="https://bitbucket.org/pypy/pypy/downloads/${MY_P}-src.tar.bz2
+ amd64? (
+ jit? ( ${BINHOST}/${P}-amd64+bzip2+jit+ncurses.tar.lz )
+ !jit? ( ${BINHOST}/${P}-amd64+bzip2+ncurses.tar.lz )
+ )
+ x86? (
+ cpu_flags_x86_sse2? (
+ jit? ( ${BINHOST}/${P}-x86+bzip2+jit+ncurses+sse2.tar.lz )
+ !jit? ( ${BINHOST}/${P}-x86+bzip2+ncurses+sse2.tar.lz )
+ )
+ !cpu_flags_x86_sse2? (
+ !jit? ( ${BINHOST}/${P}-x86+bzip2+ncurses.r1.tar.lz )
+ )
+ )"
+
+# Supported variants
+REQUIRED_USE="x86? ( !cpu_flags_x86_sse2? ( !jit ) )"
+
+LICENSE="MIT"
+# pypy3 -c 'import sysconfig; print(sysconfig.get_config_var("SOABI"))'
+SLOT="0/71-py36"
+KEYWORDS="~amd64 ~x86"
+IUSE="gdbm +jit libressl sqlite cpu_flags_x86_sse2 test tk"
+
+RDEPEND="
+ app-arch/bzip2:0/1
+ dev-libs/expat:0/0
+ dev-libs/libffi:0/7
+ sys-devel/gcc:*
+ >=sys-libs/glibc-2.28
+ sys-libs/ncurses:0/6
+ sys-libs/zlib:0/1
+ gdbm? ( sys-libs/gdbm:0= )
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
+ sqlite? ( dev-db/sqlite:3= )
+ tk? (
+ dev-lang/tk:0=
+ dev-tcltk/tix:0=
+ )
+ !dev-python/pypy3:0"
+DEPEND="${RDEPEND}
+ app-arch/lzip
+ app-arch/xz-utils
+ test? ( ${PYTHON_DEPS} )"
+
+S=${WORKDIR}/${MY_P}-src
+
+QA_PREBUILT="
+ usr/lib/pypy3.6/pypy3-c
+ usr/lib/pypy3.6/libpypy3-c.so"
+
+src_prepare() {
+ eapply "${FILESDIR}/7.0.0-gentoo-path.patch"
+ eapply "${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch"
+ eapply "${FILESDIR}"/7.0.0_all_distutils_cxx.patch
+
+ sed -e "s^@EPREFIX@^${EPREFIX}^" \
+ -i lib-python/3/distutils/command/install.py || die
+
+ # apply CPython stdlib patches
+ pushd lib-python/3 > /dev/null || die
+ eapply "${FILESDIR}"/python-3.5-distutils-OO-build.patch
+ popd > /dev/null || die
+
+ eapply_user
+}
+
+src_compile() {
+ # Tadaam! PyPy compiled!
+ mv "${WORKDIR}"/${P}*/{libpypy3-c.so,pypy3-c} . || die
+ mv "${WORKDIR}"/${P}*/include/*.h include/ || die
+ mv pypy/module/cpyext/include/*.h include/ || die
+ mv pypy/module/cpyext/parse/*.h include/ || die
+
+ pax-mark m pypy3-c libpypy3-c.so
+
+ einfo "Generating caches and CFFI modules ..."
+
+ # Generate Grammar and PatternGrammar pickles.
+ ./pypy3-c -c "import lib2to3.pygram, lib2to3.patcomp; lib2to3.patcomp.PatternCompiler()" \
+ || die "Generation of Grammar and PatternGrammar pickles failed"
+
+ # Generate cffi modules
+ # Please keep in sync with pypy/tool/build_cffi_imports.py!
+#cffi_build_scripts = {
+# "sqlite3": "_sqlite3_build.py",
+# "audioop": "_audioop_build.py",
+# "tk": "_tkinter/tklib_build.py",
+# "curses": "_curses_build.py" if sys.platform != "win32" else None,
+# "syslog": "_syslog_build.py" if sys.platform != "win32" else None,
+# "_gdbm": "_gdbm_build.py" if sys.platform != "win32" else None,
+# "pwdgrp": "_pwdgrp_build.py" if sys.platform != "win32" else None,
+# "resource": "_resource_build.py" if sys.platform != "win32" else None,
+# "lzma": "_lzma_build.py",
+# "_decimal": "_decimal_build.py",
+# "ssl": "_ssl_build.py",
+# "_blake2": "_blake2/_blake2_build.py",
+# "_sha3": "_sha3/_sha3_build.py",
+ cffi_targets=( blake2/_blake2 sha3/_sha3 ssl
+ audioop curses syslog pwdgrp resource lzma decimal )
+ use gdbm && cffi_targets+=( gdbm )
+ use sqlite && cffi_targets+=( sqlite3 )
+ use tk && cffi_targets+=( tkinter/tklib )
+
+ einfo "Please disregard the import errors during CFFI cache generation."
+ einfo "They come from modules not built yet."
+
+ local t
+ # all modules except tkinter output to .
+ # tkinter outputs to the correct dir ...
+ cd lib_pypy || die
+ for t in "${cffi_targets[@]}"; do
+ # tkinter doesn't work via -m
+ ../pypy3-c "_${t}_build.py" || die "Failed to build CFFI bindings for ${t}"
+ done
+
+ # Cleanup temporary objects
+ find -name "_cffi_*.[co]" -delete || die
+ find -type d -empty -delete || die
+}
+
+src_test() {
+ # (unset)
+ local -x PYTHONDONTWRITEBYTECODE=
+
+ # Test runner requires Python 2 too. However, it spawns PyPy3
+ # internally so that we end up testing the correct interpreter.
+ "${PYTHON}" ./pypy/test_all.py --pypy=./pypy3-c -vv lib-python || die
+}
+
+src_install() {
+ local dest=/usr/lib/pypy3.6
+ einfo "Installing PyPy ..."
+ exeinto "${dest}"
+ doexe pypy3-c libpypy3-c.so
+ pax-mark m "${ED%/}${dest}/pypy3-c" "${ED%/}${dest}/libpypy3-c.so"
+ insinto "${dest}"
+ # preserve mtimes to avoid obsoleting caches
+ insopts -p
+ doins -r include lib_pypy lib-python
+ dosym ../lib/pypy3.6/pypy3-c /usr/bin/pypy3
+ dodoc README.rst
+
+ if ! use gdbm; then
+ rm -r "${ED%/}${dest}"/lib_pypy/_gdbm* || die
+ fi
+ if ! use sqlite; then
+ rm -r "${ED%/}${dest}"/lib-python/*3/sqlite3 \
+ "${ED%/}${dest}"/lib_pypy/_sqlite3* \
+ "${ED%/}${dest}"/lib-python/*3/test/test_sqlite.py || die
+ fi
+ if ! use tk; then
+ rm -r "${ED%/}${dest}"/lib-python/*3/{idlelib,tkinter} \
+ "${ED%/}${dest}"/lib_pypy/_tkinter \
+ "${ED%/}${dest}"/lib-python/*3/test/test_{tcl,tk,ttk*}.py || die
+ fi
+
+ einfo "Generating caches and byte-compiling ..."
+
+ local -x PYTHON=${ED%/}${dest}/pypy3-c
+ # we can't use eclass function since PyPy is dumb and always gives
+ # paths relative to the interpreter
+ local PYTHON_SITEDIR=${EPREFIX}/usr/lib/pypy3.6/site-packages
+ python_export pypy3 EPYTHON
+
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
+ python_domodule epython.py
+
+ einfo "Byte-compiling Python standard library..."
+
+ # compile the installed modules
+ python_optimize "${ED%/}${dest}"
+}