summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-12 16:05:18 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-12 17:03:16 +0100
commit1220629606e4287bc60274825ccb9ab3f9db76f1 (patch)
tree796118ff88dc811231f76828a1b77efb8f87f343 /dev-python/pypy3
parentdev-lang/python: Fix epython.py module first install (diff)
downloadgentoo-1220629606e4287bc60274825ccb9ab3f9db76f1.tar.gz
gentoo-1220629606e4287bc60274825ccb9ab3f9db76f1.tar.bz2
gentoo-1220629606e4287bc60274825ccb9ab3f9db76f1.zip
dev-python/pypy*: Fix epython.py module first install
Diffstat (limited to 'dev-python/pypy3')
-rw-r--r--dev-python/pypy3/pypy3-2.4.0.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/pypy3/pypy3-2.4.0.ebuild b/dev-python/pypy3/pypy3-2.4.0.ebuild
index 47a824e12292..9c15e466801f 100644
--- a/dev-python/pypy3/pypy3-2.4.0.ebuild
+++ b/dev-python/pypy3/pypy3-2.4.0.ebuild
@@ -192,11 +192,14 @@ src_install() {
einfo "Generating caches and byte-compiling ..."
- python_export pypy3 EPYTHON PYTHON PYTHON_SITEDIR
- local PYTHON=${ED%/}${INSDESTTREE}/pypy-c
+ local -x PYTHON=${ED%/}${INSDESTTREE}/pypy-c
local -x LD_LIBRARY_PATH="${ED%/}${INSDESTTREE}"
+ # we can't use eclass function since PyPy is dumb and always gives
+ # paths relative to the interpreter
+ local PYTHON_SITEDIR=${EPREFIX}/usr/$(get_libdir)/pypy3/site-packages
+ python_export pypy3 EPYTHON
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
# Generate Grammar and PatternGrammar pickles.