summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-25 21:08:55 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-25 21:31:13 +0100
commit26c81aa26ce757615bd3273a8e48c6d825a08d24 (patch)
tree3ad8d4cabcc6064017f4f9f445b09db482c24e4a /dev-python/pypy3
parentdev-libs/oniguruma: security cleanup (bug #702012) (diff)
downloadgentoo-26c81aa26ce757615bd3273a8e48c6d825a08d24.tar.gz
gentoo-26c81aa26ce757615bd3273a8e48c6d825a08d24.tar.bz2
gentoo-26c81aa26ce757615bd3273a8e48c6d825a08d24.zip
dev-python/pypy3: Fix install after eclass changes
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypy3')
-rw-r--r--dev-python/pypy3/pypy3-7.3.0.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/dev-python/pypy3/pypy3-7.3.0.ebuild b/dev-python/pypy3/pypy3-7.3.0.ebuild
index 9ec506dc1868..1c5dfb210180 100644
--- a/dev-python/pypy3/pypy3-7.3.0.ebuild
+++ b/dev-python/pypy3/pypy3-7.3.0.ebuild
@@ -207,17 +207,13 @@ src_install() {
"${ED}${dest}"/lib-python/*3/test/test_{tcl,tk,ttk*}.py || die
fi
+ local -x EPYTHON=pypy3
local -x PYTHON=${ED}${dest}/pypy3-c
- # we can't use eclass function since PyPy is dumb and always gives
- # paths relative to the interpreter
- local PYTHON_SITEDIR=${EPREFIX}/usr/lib/pypy3.6/site-packages
- python_export pypy3 EPYTHON
echo "EPYTHON='${EPYTHON}'" > epython.py || die
+ python_moduleinto /usr/lib/pypy3.6/site-packages
python_domodule epython.py
einfo "Byte-compiling Python standard library..."
-
- # compile the installed modules
python_optimize "${ED}${dest}"
}