summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-25 21:09:52 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-25 21:31:15 +0100
commit071ce2f523a5907b8bea8620eefeb05c74b37a03 (patch)
treebc99b278ca02cac6ea69fa34e89798aec005ca91 /dev-python/pypy
parentdev-python/pypy3: Fix install after eclass changes (diff)
downloadgentoo-071ce2f523a5907b8bea8620eefeb05c74b37a03.tar.gz
gentoo-071ce2f523a5907b8bea8620eefeb05c74b37a03.tar.bz2
gentoo-071ce2f523a5907b8bea8620eefeb05c74b37a03.zip
dev-python/pypy: Fix install after eclass changes
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypy')
-rw-r--r--dev-python/pypy/pypy-7.3.0.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/dev-python/pypy/pypy-7.3.0.ebuild b/dev-python/pypy/pypy-7.3.0.ebuild
index fef3e9c742c7..15a4ffa99455 100644
--- a/dev-python/pypy/pypy-7.3.0.ebuild
+++ b/dev-python/pypy/pypy-7.3.0.ebuild
@@ -170,17 +170,13 @@ src_install() {
"${ED}${dest}"/lib-python/*2.7/test/test_{tcl,tk,ttk*}.py || die
fi
+ local -x EPYTHON=pypy
local -x PYTHON=${ED}${dest}/pypy-c
- # we can't use eclass function since PyPy is dumb and always gives
- # paths relative to the interpreter
- local PYTHON_SITEDIR=${EPREFIX}/usr/lib/pypy2.7/site-packages
- python_export pypy EPYTHON
echo "EPYTHON='${EPYTHON}'" > epython.py || die
+ python_moduleinto /usr/lib/pypy2.7/site-packages
python_domodule epython.py
einfo "Byte-compiling Python standard library..."
-
- # compile the installed modules
python_optimize "${ED}${dest}"
}