summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-25 12:06:47 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-25 12:07:00 +0200
commit2789272306f626ebce22604d0e741724f6f522e7 (patch)
tree6318e4fed059bb5b7efc175779b625321f39c544 /dev-python/pyquery/pyquery-1.2.4.ebuild
parentdev-python/cssselect: Drop pypy support again due to unsatified deps (diff)
downloadgentoo-2789272306f626ebce22604d0e741724f6f522e7.tar.gz
gentoo-2789272306f626ebce22604d0e741724f6f522e7.tar.bz2
gentoo-2789272306f626ebce22604d0e741724f6f522e7.zip
dev-python/pyquery: Drop optional dep to optfeature
Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyquery/pyquery-1.2.4.ebuild')
-rw-r--r--dev-python/pyquery/pyquery-1.2.4.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/pyquery/pyquery-1.2.4.ebuild b/dev-python/pyquery/pyquery-1.2.4.ebuild
deleted file mode 100644
index 21a1e0d5de20..000000000000
--- a/dev-python/pyquery/pyquery-1.2.4.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="A jQuery-like library for python"
-HOMEPAGE="https://pypi.python.org/pypi/pyquery"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ~ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="beautifulsoup3 test"
-
-RDEPEND=">=dev-python/lxml-2.1[beautifulsoup3?,${PYTHON_USEDEP}]
- dev-python/cssselect[${PYTHON_USEDEP}]
- >=dev-python/webob-1.2_rc1[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-REQUIRED_USE="test? ( beautifulsoup3 )"
-
-DOCS=( CHANGES.rst README.rst )
-
-python_prepare_all() {
- # Disable tests that access the net
- for file in docs/{ajax.txt,manipulating.txt,scrap.txt,tips.txt}
- do
- mv ${file} ${file/.txt/} || die
- done
- sed -e 's:>>> d = pq(url:>>> # d = pq(url:' -i README.rst || die
- sed -e 's:class TestWebScrapping:class _TestWebScrapping:' -i ${PN}/test.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}