summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-21 20:18:38 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-21 21:54:08 +0100
commitfe05ace8277a5c0e97dcf1e0ba972461018c22d5 (patch)
treec023c462f0b20dcef3ebb7bc6cd3d399c1d21674 /dev-python/pyquery
parentgames-rpg/daimonin-client: Port to EAPI 7 (diff)
downloadgentoo-fe05ace8277a5c0e97dcf1e0ba972461018c22d5.tar.gz
gentoo-fe05ace8277a5c0e97dcf1e0ba972461018c22d5.tar.bz2
gentoo-fe05ace8277a5c0e97dcf1e0ba972461018c22d5.zip
dev-python/pyquery: Bump to 1.4.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyquery')
-rw-r--r--dev-python/pyquery/Manifest1
-rw-r--r--dev-python/pyquery/pyquery-1.4.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pyquery/Manifest b/dev-python/pyquery/Manifest
index b4cd5f54f220..4f3ec79b219b 100644
--- a/dev-python/pyquery/Manifest
+++ b/dev-python/pyquery/Manifest
@@ -1 +1,2 @@
DIST pyquery-1.4.1.tar.gz 47983 BLAKE2B eb8d0ca59122734a4c715c33f40fd0b5fcc8edcabe9e41649ddf332feb1df603f8527a668aa7b9d78974b3d049e774355296644abd9b4d426d96e6e3c7a74065 SHA512 e2bfbbf51f99a408e9696a2b9c15f8875813847a10b5bd93c4c7a6886ac1b3ae6c7883ec4fb64e9bccab2127617843961e181044fe927f3c80c8ac363ed86141
+DIST pyquery-1.4.3.tar.gz 47448 BLAKE2B 32451dfc8f8160207b4be12006ceba3098b8cb344bfa3e80ccf75f8cfca9542614ae78b9bfec773139cbbf12434201f92f8b4738e7d9e6241b3addfeb1bc8dda SHA512 cb61326e38f78763ca15de09e3a56dad776b3d4831b54eabf295db0f9af8bf04599642c73f5db3e3172b86d7b66ba2ef626c8cba2dfb458af6ac432d15ea7cba
diff --git a/dev-python/pyquery/pyquery-1.4.3.ebuild b/dev-python/pyquery/pyquery-1.4.3.ebuild
new file mode 100644
index 000000000000..cbc62b48fde8
--- /dev/null
+++ b/dev-python/pyquery/pyquery-1.4.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A jQuery-like library for python"
+HOMEPAGE="https://github.com/gawel/pyquery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/lxml-2.1[${PYTHON_USEDEP}]
+ >dev-python/cssselect-0.7.9[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.1.9[${PYTHON_USEDEP}]"
+DEPEND="
+ test? ( ${RDEPEND}
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ )"
+
+RESTRICT+=" !test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/pyquery-1.4.1-network-tests.patch"
+ "${FILESDIR}/pyquery-1.4.1-tests-pypy.patch"
+)
+
+python_test() {
+ # The suite, it appears, requires this hard setting of PYTHONPATH!
+ PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
+}