summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-06 11:12:20 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-07 20:43:25 +0200
commite7acd95904e0de0214e2322327078a7982e5fbc4 (patch)
tree0273fefbe61cc7473a0588e3dde6f91dea898e08 /dev-python/pyramid/pyramid-1.5.7-r1.ebuild
parentdev-python/zope-deprecation: New package, dep of dev-python/pyramid (diff)
downloadgentoo-e7acd95904e0de0214e2322327078a7982e5fbc4.tar.gz
gentoo-e7acd95904e0de0214e2322327078a7982e5fbc4.tar.bz2
gentoo-e7acd95904e0de0214e2322327078a7982e5fbc4.zip
dev-python/pyramid: Fix deps, enable tests
Correct the package dependencies, and enable tests. The former includes: 1. putting dev-python/setuptools in RDEPEND since the package uses entry_points (pkg_resources), 2. adding dev-python/zope-deprecation to RDEPEND since the package states that as a runtime dependency, 3. removing nose & coverage from test dependencies since they are not used for testing upstream (it is extra dep for post-install testing but setup.py and the tests use plain unittest), 4. adding missing py2-conditional dependency on dev-python/zope-component for tests. Appropriately switch python_test() to use 'setup.py test'.
Diffstat (limited to 'dev-python/pyramid/pyramid-1.5.7-r1.ebuild')
-rw-r--r--dev-python/pyramid/pyramid-1.5.7-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyramid/pyramid-1.5.7-r1.ebuild b/dev-python/pyramid/pyramid-1.5.7-r1.ebuild
new file mode 100644
index 000000000000..99de90acd49b
--- /dev/null
+++ b/dev-python/pyramid/pyramid-1.5.7-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A small open source Python web framework"
+HOMEPAGE="http://www.pylonsproject.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/chameleon[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/repoze-lru[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/zope-deprecation[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/translationstring[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/venusian[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/webtest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/zope-component[${PYTHON_USEDEP}]' \
+ 'python2*' pypy)
+ )"
+
+python_test() {
+ esetup.py test
+}