summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-06 11:19:45 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-07 20:43:26 +0200
commitbb3c9b713e74c4305626948c02664a573834c561 (patch)
tree6f0dd38be81fb3107ae479e2bf576858d04ba0c2 /dev-python/pyramid
parentdev-python/pyramid: Fix deps, enable tests (diff)
downloadgentoo-bb3c9b713e74c4305626948c02664a573834c561.tar.gz
gentoo-bb3c9b713e74c4305626948c02664a573834c561.tar.bz2
gentoo-bb3c9b713e74c4305626948c02664a573834c561.zip
dev-python/pyramid: Bump to 1.5.8 (to fix tests)
Diffstat (limited to 'dev-python/pyramid')
-rw-r--r--dev-python/pyramid/Manifest1
-rw-r--r--dev-python/pyramid/pyramid-1.5.8.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyramid/Manifest b/dev-python/pyramid/Manifest
index c50399674db8..c16b479d38b2 100644
--- a/dev-python/pyramid/Manifest
+++ b/dev-python/pyramid/Manifest
@@ -1,2 +1,3 @@
DIST pyramid-1.5.1.tar.gz 2401767 SHA256 2fe0b4012f10444682acc0df3b9cb85c7cfff2508ba5cbe6db83f5f14b510d86 SHA512 70b04111020d0f02ef21c52c44d7b6a5e78d198daee0068921df048bcae8b07567aee05d57f1a9e7329ef418116a0f7682aee30c6f785a4d1ec847e2519e7cc5 WHIRLPOOL 16e17ccba24f6a76c4ef0f2e361580e832c6450f453f88229bf1204cd123719e08e8565bb46d8b0bef5b395af2dfa87cb7ac7a9dc0dc9a0cc2d019490716e151
DIST pyramid-1.5.7.tar.gz 2678474 SHA256 c1302d5ccb6833e8794ddb649aa9bb64d86c05adb127c93e329f8863907449b4 SHA512 32b0d4b85bf0f471b7c08ac7353f2859284ee7bb2451b68429074fb5f954e0e02d7bc4bdd86f843d6a5304b56a418e698d614806bbfd09dda9a608db88c25949 WHIRLPOOL 2c12aab5e91eede072f0b45b510699f048f9848753cf134e21dcb775b0f2fa96c815d1573cd11b67afa76f401bdab230b67fe1a24a8a861708309d8b26308619
+DIST pyramid-1.5.8.tar.gz 2546802 SHA256 51474d93b80a9e55cc120f911eeb11c4728bb0ec5ff40495d28ff9977685eda5 SHA512 725f472245c03a50463d9e8946dbc71063ef46d58df8a41804d1c68bb0abe796f7fcd36f7c1708f8597a980f8cb308fbeec0bbad3f82c0e7d3eb449f6719fe16 WHIRLPOOL a2e9ce852fad1e491d6b1cbc01669e1f4fd67b512a345040ac975a6b2b2dc4245c21b479b6009ebfbc9aa05502c216e1bb396e33ed09c7907163960d25b79103
diff --git a/dev-python/pyramid/pyramid-1.5.8.ebuild b/dev-python/pyramid/pyramid-1.5.8.ebuild
new file mode 100644
index 000000000000..99de90acd49b
--- /dev/null
+++ b/dev-python/pyramid/pyramid-1.5.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A small open source Python web framework"
+HOMEPAGE="http://www.pylonsproject.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/chameleon[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/repoze-lru[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/zope-deprecation[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/translationstring[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/venusian[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/webtest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/zope-component[${PYTHON_USEDEP}]' \
+ 'python2*' pypy)
+ )"
+
+python_test() {
+ esetup.py test
+}