summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-09 22:36:40 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-10 00:16:25 +0200
commit0d59ddca1ea80cbe59690225a039509835af25da (patch)
tree4d645f9e8ce97b15fc3a4fee7f93fe839a3a66d9 /dev-python/pyrsistent
parentsys-kernel/gentoo-kernel: Bump to 5.8.8 (diff)
downloadgentoo-0d59ddca1ea80cbe59690225a039509835af25da.tar.gz
gentoo-0d59ddca1ea80cbe59690225a039509835af25da.tar.bz2
gentoo-0d59ddca1ea80cbe59690225a039509835af25da.zip
dev-python/pyrsistent: Bump to 0.17.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyrsistent')
-rw-r--r--dev-python/pyrsistent/Manifest1
-rw-r--r--dev-python/pyrsistent/pyrsistent-0.17.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pyrsistent/Manifest b/dev-python/pyrsistent/Manifest
index edd6c19a4c08..4c1f66c8fd2d 100644
--- a/dev-python/pyrsistent/Manifest
+++ b/dev-python/pyrsistent/Manifest
@@ -1,3 +1,4 @@
DIST pyrsistent-0.15.6.tar.gz 107424 BLAKE2B 432ce7223fee524cbcd65237171af6f0fa16d23dfcc65b7cb5bc8d19dc8216344bf21660d2acf9b07eb1bc9b883840c0b5de679cfe52a0f977e64cea21cd584f SHA512 42b259c66e118d5b09bcc64e57441729146ed9b40e9fd18cda83c4aa0523d5bc3acde3177113e1f2a1b5c1e3a14d15b369df9701a9218a88a656ba0359b5ff10
DIST pyrsistent-0.16.0.tar.gz 108012 BLAKE2B 62283b8ef478302964fc6b1869c3646c23b78762c5f4fad68aa239433c54d9c652544d5ce05dee18107c8f9604b689043d07f67b9396f6dce0cce3aab022e2de SHA512 d5764b1a185d4578bf308f338037e0546b06e79a3e7189b904e24e95e0e907bc98d7c1c68becc5549a541a5864df75aba6088cafa3558ecb0a63dafb22f5674a
DIST pyrsistent-0.17.0.tar.gz 106451 BLAKE2B 6d752f9d396b03cc6391979cb908b4b1a112e160e31961cd7d437f789c99a61c8dfa1406ad18c0873f96a3609e779e12cadcd2d75dd290e4ef4ca1a4e4feaf0e SHA512 e361b1e7e53153fd6d8195766e548a9c708624f2f8ba1c05c1c137306f11f336bffc95d62b6484ee810e71d96ca9faa703b1ebb4e8ff485f28371ecaf5ea27f1
+DIST pyrsistent-0.17.2.tar.gz 106594 BLAKE2B c6135f45b43d4742ac39c722636b42813c24823e5319dc34f4c3f2e97a0e311046bc7cfef305cc0710fb26c5b7b595963953307485645c35d1ccc75383ec08df SHA512 58b78457481b188b65bfbe29da1318128795732b8c98ff89b1bdec1741d821807ae120000ae79115b2c4881f328dd8853e7ae48b0406e0e7fc69fca3c41fcd6f
diff --git a/dev-python/pyrsistent/pyrsistent-0.17.2.ebuild b/dev-python/pyrsistent/pyrsistent-0.17.2.ebuild
new file mode 100644
index 000000000000..e732f866136e
--- /dev/null
+++ b/dev-python/pyrsistent/pyrsistent-0.17.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Persistent/Functional/Immutable data structures"
+HOMEPAGE="https://github.com/tobgu/pyrsistent/ https://pypi.org/project/pyrsistent/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest