summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-17 21:40:24 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-17 21:40:24 +0200
commit4712306e0e69941cfafe37792b85162c2d6e6876 (patch)
tree4490535a51e59760d419360f30338f782d9a9993 /dev-python/pyscard/pyscard-2.0.1.ebuild
parentdev-python/pyicu: Bump to 2.7.4 (diff)
downloadgentoo-4712306e0e69941cfafe37792b85162c2d6e6876.tar.gz
gentoo-4712306e0e69941cfafe37792b85162c2d6e6876.tar.bz2
gentoo-4712306e0e69941cfafe37792b85162c2d6e6876.zip
dev-python/pyscard: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyscard/pyscard-2.0.1.ebuild')
-rw-r--r--dev-python/pyscard/pyscard-2.0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyscard/pyscard-2.0.1.ebuild b/dev-python/pyscard/pyscard-2.0.1.ebuild
new file mode 100644
index 000000000000..f40381afb5e8
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard
+ https://pypi.org/project/pyscard/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="sys-apps/pcsc-lite"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/swig"
+
+distutils_enable_tests setup.py
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/pyro
+}