summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-01 12:37:08 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-01 12:55:32 +0200
commit34304d85abbd61039df891e530c2b1873074a165 (patch)
tree5244ba3aa0a3aa49a505d4c590138b05ad9d2cd7 /dev-python/pyscreenshot
parentdev-python/easyprocess: enable py3.11, pep517 (diff)
downloadgentoo-34304d85abbd61039df891e530c2b1873074a165.tar.gz
gentoo-34304d85abbd61039df891e530c2b1873074a165.tar.bz2
gentoo-34304d85abbd61039df891e530c2b1873074a165.zip
dev-python/pyscreenshot: update EAPI 7 -> 8, pep517, enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pyscreenshot')
-rw-r--r--dev-python/pyscreenshot/pyscreenshot-3.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyscreenshot/pyscreenshot-3.0-r1.ebuild b/dev-python/pyscreenshot/pyscreenshot-3.0-r1.ebuild
new file mode 100644
index 000000000000..673bf65d8b11
--- /dev/null
+++ b/dev-python/pyscreenshot/pyscreenshot-3.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python screenshot library"
+HOMEPAGE="https://github.com/ponty/pyscreenshot"
+SRC_URI="https://github.com/ponty/pyscreenshot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/easyprocess[${PYTHON_USEDEP}]
+ dev-python/entrypoint2[${PYTHON_USEDEP}]
+ dev-python/jeepney[${PYTHON_USEDEP}]
+ dev-python/mss[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ media-gfx/imagemagick
+ media-gfx/pqiv
+ x11-apps/xdpyinfo
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # skip GNOME/KDE tests that require D-BUS
+ local -x XDG_CURRENT_DESKTOP=none
+ virtx epytest --deselect tests/test_check.py::test_speedtest
+}