summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-27 14:09:18 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-27 14:15:53 +0200
commitd9c54b0ae3d80b4125d87bda0964cb956cd3284a (patch)
tree8aa6e71d010bbf84551bc39ca5827bf3ffd7d27e /dev-python/pyside6-tools
parentdev-python/pyside6-tools: add 6.3.2 (diff)
downloadgentoo-d9c54b0ae3d80b4125d87bda0964cb956cd3284a.tar.gz
gentoo-d9c54b0ae3d80b4125d87bda0964cb956cd3284a.tar.bz2
gentoo-d9c54b0ae3d80b4125d87bda0964cb956cd3284a.zip
dev-python/pyside6-tools: drop 6.3.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pyside6-tools')
-rw-r--r--dev-python/pyside6-tools/Manifest1
-rw-r--r--dev-python/pyside6-tools/pyside6-tools-6.3.1.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/pyside6-tools/Manifest b/dev-python/pyside6-tools/Manifest
index 7d68dcdf8809..d775a81b0c8a 100644
--- a/dev-python/pyside6-tools/Manifest
+++ b/dev-python/pyside6-tools/Manifest
@@ -1,2 +1 @@
-DIST pyside-setup-opensource-src-6.3.1.tar.xz 7685896 BLAKE2B 66eb9ced1899fabea2be1b6471fcaa3eca4c74e989e7eab47dc44db623eb6242a713e1e7c7e2a6daad36994d3766cf7adc79e3601bfc3908a051fdc97b52522f SHA512 81751fa9e2c492ceae42b3cb1f871d3f95f56cc07c382f02574899f3eab8db52453b0b636e63d53e0d2195f1686a01ad2bee20953aa0a8237719ec06d2b6e321
DIST pyside-setup-opensource-src-6.3.2.tar.xz 7853068 BLAKE2B 5b39e2f98bca0155d3f6617be206b759b628d0126fd30d76d67352c5c78a385938ce61a3c42b75343b9fde708e9f66617122c687ea9ecffca9cd0ab3af91a2ff SHA512 8d25d20b64ac7874e9b7866f101b6bfd7b6fe1fffa602fec6113e1fdaa11608f14a58c2ae1d87b45ee3eac6a07bd55e66dbbd222727cfe6860d8f444bc2b1ff0
diff --git a/dev-python/pyside6-tools/pyside6-tools-6.3.1.ebuild b/dev-python/pyside6-tools/pyside6-tools-6.3.1.ebuild
deleted file mode 100644
index 41ea6d4bbe2f..000000000000
--- a/dev-python/pyside6-tools/pyside6-tools-6.3.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# TODO: Add PyPy once officially supported. See also:
-# https://bugreports.qt.io/browse/PYSIDE-535
-PYTHON_COMPAT=( python3_{8..10} )
-CMAKE_IN_SOURCE_BUILD=1
-
-inherit cmake python-r1
-
-MY_P=pyside-setup-opensource-src-${PV}
-
-DESCRIPTION="PySide development tools (pyside6-lupdate with support for Python)"
-HOMEPAGE="https://wiki.qt.io/PySide6"
-SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside6/PySide6-${PV}-src/${MY_P}.tar.xz"
-S="${WORKDIR}/${MY_P}/sources/pyside-tools"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- >=dev-python/pyside6-${PV}[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- cmake_src_prepare
-
- python_copy_sources
-}
-
-src_configure() {
- pyside-tools_configure() {
- local mycmakeargs=(
- # the tools conflict with tools from Qt
- -DNO_QT_TOOLS=yes
- )
- CMAKE_USE_DIR="${BUILD_DIR}" cmake_src_configure
- }
-
- python_foreach_impl pyside-tools_configure
-}
-
-src_compile() {
- pyside-tools_compile() {
- CMAKE_USE_DIR="${BUILD_DIR}" cmake_src_compile
- }
-
- python_foreach_impl pyside-tools_compile
-}
-
-src_install() {
- pyside-tools_install() {
- python_doexe "${BUILD_DIR}/"*.py
- }
-
- python_foreach_impl pyside-tools_install
-
- einstalldocs
-}