summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-04-19 15:09:50 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-04-19 15:19:17 +0200
commit4cdb8d6af44787fe96ffb7c547e9ea99147d0115 (patch)
treef259b04c264cd17b7c5eb30740d292c6e2142f38 /dev-python/pyspf/pyspf-2.0.12.ebuild
parentnet-misc/spice-gtk: Fix gtk+ pkg ref (diff)
downloadgentoo-4cdb8d6af44787fe96ffb7c547e9ea99147d0115.tar.gz
gentoo-4cdb8d6af44787fe96ffb7c547e9ea99147d0115.tar.bz2
gentoo-4cdb8d6af44787fe96ffb7c547e9ea99147d0115.zip
dev-python/pyspf: Bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/pyspf/pyspf-2.0.12.ebuild')
-rw-r--r--dev-python/pyspf/pyspf-2.0.12.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyspf/pyspf-2.0.12.ebuild b/dev-python/pyspf/pyspf-2.0.12.ebuild
new file mode 100644
index 000000000000..b1bbae67e850
--- /dev/null
+++ b/dev-python/pyspf/pyspf-2.0.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="ipv6?"
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sender Policy Framework (SPF) protocol"
+HOMEPAGE="https://pypi.python.org/pypi/pyspf"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}t.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 test"
+
+# >=python-3.3 comes with the built-in ipaddress module
+RDEPEND="dev-python/authres[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/ipaddr-2.1.10[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/pydns:2[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/pydns:3[${PYTHON_USEDEP}]' 'python3*')"
+
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="test? ( ipv6 )"
+
+python_test() {
+ pushd test &> /dev/null
+ "${PYTHON}" testspf.py || die
+ popd &> /dev/null
+}