summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-12 23:33:37 +0000
committerSam James <sam@gentoo.org>2021-01-12 23:34:13 +0000
commita1056a55e3a42a62cc33d4aea82cc184e315b590 (patch)
treebb90c5245c76846c218673f38bd8d7a0522dcdc9 /dev-python/pyspf
parentdev-libs/libdnet: add Python 3.9 (diff)
downloadgentoo-a1056a55e3a42a62cc33d4aea82cc184e315b590.tar.gz
gentoo-a1056a55e3a42a62cc33d4aea82cc184e315b590.tar.bz2
gentoo-a1056a55e3a42a62cc33d4aea82cc184e315b590.zip
dev-python/pyspf: add Python 3.9
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyspf')
-rw-r--r--dev-python/pyspf/pyspf-2.0.14.ebuild31
1 files changed, 19 insertions, 12 deletions
diff --git a/dev-python/pyspf/pyspf-2.0.14.ebuild b/dev-python/pyspf/pyspf-2.0.14.ebuild
index 97a34c45d65f..ca804235f393 100644
--- a/dev-python/pyspf/pyspf-2.0.14.ebuild
+++ b/dev-python/pyspf/pyspf-2.0.14.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
PYTHON_REQ_USE="ipv6?"
DISTUTILS_USE_SETUPTOOLS=no
@@ -17,19 +17,26 @@ LICENSE="PSF-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="ipv6 test"
+REQUIRED_USE="test? ( ipv6 )"
RESTRICT="!test? ( test )"
-RDEPEND="dev-python/authres[${PYTHON_USEDEP}]
- || ( dev-python/pydns:3[${PYTHON_USEDEP}]
- dev-python/dnspython[${PYTHON_USEDEP}] )"
-
-DEPEND="test? ( ${RDEPEND}
- dev-python/pyyaml[${PYTHON_USEDEP}] )"
-
-REQUIRED_USE="test? ( ipv6 )"
+RDEPEND="
+ dev-python/authres[${PYTHON_USEDEP}]
+ || (
+ dev-python/pydns:3[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ )
+"
+
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
python_test() {
- pushd test &> /dev/null
+ pushd test &> /dev/null || die
"${PYTHON}" testspf.py || die
- popd &> /dev/null
+ popd &> /dev/null || die
}