summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-05-03 18:51:40 -0700
committerZac Medico <zmedico@gentoo.org>2020-05-03 18:54:45 -0700
commit93b9fca29cccb66846a5b95edc96fd05171c777a (patch)
treef15df3338bcfb71aa5bd227d712ad7af6d7c37ae /dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0-r1.ebuild
parentdev-python/aiohttp: Add new version 3.6.2 (diff)
downloadgentoo-93b9fca29cccb66846a5b95edc96fd05171c777a.tar.gz
gentoo-93b9fca29cccb66846a5b95edc96fd05171c777a.tar.bz2
gentoo-93b9fca29cccb66846a5b95edc96fd05171c777a.zip
dev-python/pytest-aiohttp: 0.3.0-r1 revbump to require pytest-5.4
Solves this issue: /usr/lib64/python3.6/site-packages/pytest_asyncio/plugin.py:39: in pytest_pycollect_makeitem item = pytest.Function.from_parent(collector, name=name) E AttributeError: type object 'Function' has no attribute 'from_parent' See: https://github.com/gentoo/gentoo/pull/15435#discussion_r412989852 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0-r1.ebuild')
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0-r1.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..733b6f0e1963
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-0.22.0[${PYTHON_USEDEP}]
+"