summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-30 16:24:08 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-30 16:39:31 +0200
commit25e72763bb0b80e8fead3c85ee5adbd03fb291a9 (patch)
tree102e0a76e96454722a41e6389ca3b818b03fd089 /dev-python/pytest-asyncio
parentkde-plasma: Drop KDE Plasma 5.16.3 (diff)
downloadgentoo-25e72763bb0b80e8fead3c85ee5adbd03fb291a9.tar.gz
gentoo-25e72763bb0b80e8fead3c85ee5adbd03fb291a9.tar.bz2
gentoo-25e72763bb0b80e8fead3c85ee5adbd03fb291a9.zip
dev-python/pytest-asyncio: New package
Add pytest-asyncio package, a test-dep of dev-python/aiohttp-socks. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest1
-rw-r--r--dev-python/pytest-asyncio/metadata.xml7
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild35
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
new file mode 100644
index 000000000000..e74701959d85
--- /dev/null
+++ b/dev-python/pytest-asyncio/Manifest
@@ -0,0 +1 @@
+DIST pytest-asyncio-0.10.0.tar.gz 13968 BLAKE2B 4e63d527b20c767b8f0777ed684a15abe54009be72db8a50ca3b37ef95dceb884168d8081c651e2bbd6d818529d6809bb3498055fedc7f951f5675d58f50e408 SHA512 78160d1918c5d3d2172f74fa07bf4bf6d0bc416666011dd5b83b3a7f385ec30fc65d49c01bba5dd0e16ad9dcd9d72d8ab062526f3268d60cd2e24a35b5a8f883
diff --git a/dev-python/pytest-asyncio/metadata.xml b/dev-python/pytest-asyncio/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/pytest-asyncio/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
new file mode 100644
index 000000000000..ee183d8b8079
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+ https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/async_generator[${PYTHON_USEDEP}]' \
+ python3_5)"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}