summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-17 08:45:10 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-17 09:14:59 +0200
commit38bb396aa1205efef4970ef42d28a9ea06e88fbf (patch)
tree73277611de2228425472e28d879979ce1206bbd2 /dev-python/pytest-asyncio
parentdev-python/matplotlib-inline: Remove old (diff)
downloadgentoo-38bb396aa1205efef4970ef42d28a9ea06e88fbf.tar.gz
gentoo-38bb396aa1205efef4970ef42d28a9ea06e88fbf.tar.bz2
gentoo-38bb396aa1205efef4970ef42d28a9ea06e88fbf.zip
dev-python/pytest-asyncio: Bump to 0.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest1
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.16.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 6014cabf9064..3f306596d278 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1 +1,2 @@
DIST pytest-asyncio-0.15.1.tar.gz 15653 BLAKE2B 8f10c46672a18d6992248482f9e3eb68ca9d3bae5163d5924e6363a15bc97dbfdc8b9dfc21a8a89ee4a6e21d76b083b1aa5a077fe581f0f2f0bd4c5a7b519cc9 SHA512 1813d49e0dd55f563d9bf058e009da61a17f61e081cc53626b5f1db623ba04905b6bea3ecba423dc931668053310176b634339d6526c7ea729d9aad87e4f044d
+DIST pytest-asyncio-0.16.0.tar.gz 15819 BLAKE2B c999b8680a45704bcb6f4690a910aa3d2edd9965e53cf4eb59dc8119696add4553d6b3e1b010c3cac52c8fd8563be8c86afe0616132a274e73df673630b032a7 SHA512 f0059a6d05bf0c4e208f0058e30d5baf8284e630b8b91fa217f52eec18abe6b057dabfdadce2c5282e02bd4ea4cdb27f9ef62c4c308375cce1795d75a036db22
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.16.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.16.0.ebuild
new file mode 100644
index 000000000000..c6de120f92c7
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.16.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+ https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest