summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-20 15:31:09 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-20 17:48:52 +0200
commit92e194256d26f409455793d44513fb911783e0a3 (patch)
tree234da3a5b610429291290789b9d1104975460acc /dev-python/pytest-asyncio
parentdev-python/pytest-asyncio: Enable py3.8 (diff)
downloadgentoo-92e194256d26f409455793d44513fb911783e0a3.tar.gz
gentoo-92e194256d26f409455793d44513fb911783e0a3.tar.bz2
gentoo-92e194256d26f409455793d44513fb911783e0a3.zip
dev-python/pytest-asyncio: Set DISTUTILS_USE_SETUPTOOLS
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
index e56c6cce8a45..f7b4cfba907b 100644
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
@@ -3,7 +3,9 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{6,7,8} )
+
inherit distutils-r1
DESCRIPTION="Library for testing asyncio code with pytest"
@@ -18,9 +20,8 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="
test? (
${RDEPEND}
dev-python/async_generator[${PYTHON_USEDEP}]