summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-20 01:16:58 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-20 03:01:02 -0400
commit115179f176298b846b2184a6e31dc00ab8b03e15 (patch)
tree7b4107286179a0d935153dc38872e7e15d72b456 /dev-python/pytest-bdd
parentdev-cpp/cli11: drop 2.3.2 (diff)
downloadgentoo-115179f176298b846b2184a6e31dc00ab8b03e15.tar.gz
gentoo-115179f176298b846b2184a6e31dc00ab8b03e15.tar.bz2
gentoo-115179f176298b846b2184a6e31dc00ab8b03e15.zip
dev-python/pytest-bdd: drop 7.1.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest1
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-7.1.1.ebuild43
2 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index dab72680913a..fe47a368504b 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1,3 +1,2 @@
DIST pytest-bdd-7.0.1.gh.tar.gz 80315 BLAKE2B 7838a71fc6f0e7a86337d3b4d4fb9e0e7a3a0149c4271ecd75b5c9b40a28ad6bf3d6ccbc90d4a49a5472ae158f7710d98f91be340e67995ba47ea729584d16e5 SHA512 60d9713485a4719c6589e6641b45045e79c063278359c14ccbd016a6b0a8c8eebbf93e61d59e037988247c0116023910aa5e6776896b64dc96dcc23d0dbf6e3b
-DIST pytest-bdd-7.1.1.gh.tar.gz 81072 BLAKE2B 72e807a08176566fc3414dd409bf53d17da13f3a8c6c3e9596a7185174bf8ad876175570601b1db3b5657d7db084cc1c28bed1090ade87fc50c9fe810bfc68e1 SHA512 854e923318ea6d480d11a88231be941b49ac3c16a1f00fb043c962206fb511d1a65ccd92996e820ff4aad4d5c02346aa0c6d5fd482dfe03fa8b065aedec11dd3
DIST pytest-bdd-7.1.2.gh.tar.gz 81260 BLAKE2B 5120a79a5c085976f379afbd4ae7bc68c0d07a8517b6653bb2c94407b9964cd3adcfc92e8abc31cb658caa5c108e0590913c13cbcc408021841b91dbf52b8124 SHA512 7630b119649502e36d7ae2b6027c11b667513eab451511104076617e50de1456ee4b2ff128254ac0db630556258704e21e2a5e73ce9afc20ed403d0186c0a226
diff --git a/dev-python/pytest-bdd/pytest-bdd-7.1.1.ebuild b/dev-python/pytest-bdd/pytest-bdd-7.1.1.ebuild
deleted file mode 100644
index a70fd8aae5b0..000000000000
--- a/dev-python/pytest-bdd/pytest-bdd-7.1.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1
-
-DESCRIPTION="BDD library for the pytest runner"
-HOMEPAGE="https://pytest-bdd.readthedocs.io/"
-SRC_URI="
- https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- dev-python/parse_type[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-DOCS=( AUTHORS.rst CHANGES.rst README.rst )
-
-src_test() {
- # terminal_reporter test needs exact wrapping
- local -x COLUMNS=80
-
- # hooks output parsing may be affected by other pytest-*, e.g. tornasync
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_bdd.plugin
-
- distutils-r1_src_test
-}