summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-08-11 03:11:42 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-08-11 03:37:11 -0400
commit23c6d2c619a411fc8c0aa756d00dc99b9e859393 (patch)
tree6dc508c42d574b4363c7a009ae65583f213472d7 /dev-python/pytest-bdd
parentnet-misc/ytfzf: drop 2.4.0 (diff)
downloadgentoo-23c6d2c619a411fc8c0aa756d00dc99b9e859393.tar.gz
gentoo-23c6d2c619a411fc8c0aa756d00dc99b9e859393.tar.bz2
gentoo-23c6d2c619a411fc8c0aa756d00dc99b9e859393.zip
dev-python/pytest-bdd: drop 5.0.0-r1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest1
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-5.0.0-r1.ebuild39
2 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index d15d7edff11a..432f90cfff35 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1,2 +1 @@
-DIST pytest-bdd-5.0.0.gh.tar.gz 61174 BLAKE2B 6dd1d53614226d3515b0f61f71822363b559aa45789bab7f3416c75e603e87a1fe48627f36862f44bfa7ac6ec5023ad8afde6054ec67fc9a2e756be7de729fd1 SHA512 827e57d410b05207b6c646062ddb54b677e22441311820d3bd406df202b6e9344dedf59cd4868e89cfbf8606fe3f15559e4cc3958d100e4fa74f9b864e6faada
DIST pytest-bdd-6.0.1.gh.tar.gz 60932 BLAKE2B 67e0dbc251ce94da40033641f37e6c9ad70ca947f71db1a78907a6890d96d8d3112d57a2a63dda526c8f846010d39a575cb5d93a102f4653705d4229ee14ab07 SHA512 30bc697ae177e3f311af0c781e99bde5b491dfef28109359c0d80f33feb8b0b170ffe15c288fe73a624144a1d1c3223b220d591b4acc30d1ad53600482bef87d
diff --git a/dev-python/pytest-bdd/pytest-bdd-5.0.0-r1.ebuild b/dev-python/pytest-bdd/pytest-bdd-5.0.0-r1.ebuild
deleted file mode 100644
index edc44c97450b..000000000000
--- a/dev-python/pytest-bdd/pytest-bdd-5.0.0-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1
-
-DESCRIPTION="BDD library for the pytest runner"
-HOMEPAGE="https://pypi.org/project/pytest-bdd/"
-SRC_URI="https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~x86"
-
-RDEPEND="
- dev-python/glob2[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- dev-python/parse_type[${PYTHON_USEDEP}]
- dev-python/py[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-DOCS=( AUTHORS.rst CHANGES.rst README.rst )
-
-src_test() {
- # terminal_reporter test needs exact wrapping
- local -x COLUMNS=80
-
- # hooks output parsing may be affected by other pytest-*, e.g. tornasync
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_bdd.plugin
-
- distutils-r1_src_test
-}