summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-01 15:31:51 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-02 09:04:53 -0400
commitd74d3cb43d6b8993f38c42648a7f6019609b0de7 (patch)
tree5faea6e236709f39865a44ac65bbd9f9744308cb /dev-python/pytest-bdd
parentapp-emulation/vkd3d: drop 1.10 (diff)
downloadgentoo-d74d3cb43d6b8993f38c42648a7f6019609b0de7.tar.gz
gentoo-d74d3cb43d6b8993f38c42648a7f6019609b0de7.tar.bz2
gentoo-d74d3cb43d6b8993f38c42648a7f6019609b0de7.zip
dev-python/pytest-bdd: drop 7.0.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest1
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-7.0.1.ebuild48
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index fe47a368504b..9e28e80cea5b 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1,2 +1 @@
-DIST pytest-bdd-7.0.1.gh.tar.gz 80315 BLAKE2B 7838a71fc6f0e7a86337d3b4d4fb9e0e7a3a0149c4271ecd75b5c9b40a28ad6bf3d6ccbc90d4a49a5472ae158f7710d98f91be340e67995ba47ea729584d16e5 SHA512 60d9713485a4719c6589e6641b45045e79c063278359c14ccbd016a6b0a8c8eebbf93e61d59e037988247c0116023910aa5e6776896b64dc96dcc23d0dbf6e3b
DIST pytest-bdd-7.1.2.gh.tar.gz 81260 BLAKE2B 5120a79a5c085976f379afbd4ae7bc68c0d07a8517b6653bb2c94407b9964cd3adcfc92e8abc31cb658caa5c108e0590913c13cbcc408021841b91dbf52b8124 SHA512 7630b119649502e36d7ae2b6027c11b667513eab451511104076617e50de1456ee4b2ff128254ac0db630556258704e21e2a5e73ce9afc20ed403d0186c0a226
diff --git a/dev-python/pytest-bdd/pytest-bdd-7.0.1.ebuild b/dev-python/pytest-bdd/pytest-bdd-7.0.1.ebuild
deleted file mode 100644
index bc6223fab65a..000000000000
--- a/dev-python/pytest-bdd/pytest-bdd-7.0.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1
-
-DESCRIPTION="BDD library for the pytest runner"
-HOMEPAGE="https://pytest-bdd.readthedocs.io/"
-SRC_URI="
- https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~x86"
-
-RDEPEND="
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- dev-python/parse_type[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-DOCS=( AUTHORS.rst CHANGES.rst README.rst )
-
-src_test() {
- # terminal_reporter test needs exact wrapping
- local -x COLUMNS=80
-
- # hooks output parsing may be affected by other pytest-*, e.g. tornasync
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_bdd.plugin
-
- distutils-r1_src_test
-}