summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-02 11:04:36 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-02 11:04:36 +0200
commit293c031a2a09b4ff3ac780f118b8d76f9486ca38 (patch)
treecb543853643c19a103e2bef2e217d7b465c2ba35 /dev-python/pytest-cache
parentdev-python/pep8: Recombine impls into a single ebuild (diff)
downloadgentoo-293c031a2a09b4ff3ac780f118b8d76f9486ca38.tar.gz
gentoo-293c031a2a09b4ff3ac780f118b8d76f9486ca38.tar.bz2
gentoo-293c031a2a09b4ff3ac780f118b8d76f9486ca38.zip
dev-python/pytest-cache: Recombine impls into a single ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-cache')
-rw-r--r--dev-python/pytest-cache/pytest-cache-1.0-r2.ebuild2
-rw-r--r--dev-python/pytest-cache/pytest-cache-1.0-r3.ebuild32
2 files changed, 1 insertions, 33 deletions
diff --git a/dev-python/pytest-cache/pytest-cache-1.0-r2.ebuild b/dev-python/pytest-cache/pytest-cache-1.0-r2.ebuild
index 392412f86a55..375ed19f4645 100644
--- a/dev-python/pytest-cache/pytest-cache-1.0-r2.ebuild
+++ b/dev-python/pytest-cache/pytest-cache-1.0-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
inherit distutils-r1
diff --git a/dev-python/pytest-cache/pytest-cache-1.0-r3.ebuild b/dev-python/pytest-cache/pytest-cache-1.0-r3.ebuild
deleted file mode 100644
index 32f786371d38..000000000000
--- a/dev-python/pytest-cache/pytest-cache-1.0-r3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="mechanisms for caching across test runs"
-HOMEPAGE="https://pypi.org/project/pytest-cache/
- https://bitbucket.org/hpk42/pytest-cache/
- https://pythonhosted.org/pytest-cache/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="dev-python/execnet[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
- "
-
-# https://bitbucket.org/hpk42/pytest-cache/issues/12
-RESTRICT=test
-
-python_test() {
- PYTEST_PLUGINS="pytest_cache" py.test -v -v || die
-}